New stable build broken? Touch not working, flashing stopped.

0 favourites
  • 10 posts
From the Asset Store
Create your own beautiful snowman in this fun game!
  • Hi! I updated to the latest stable build but my andriod export (debug apk) stopped working after a few moments. All buttons (use Touch on Tap on Object) are not doing anything, one flashing button every 6 seconds stopped flashing. And the button to display an iframe on a hidden layer (toggle layer visibility) does not do anything either. It works in preview on PC. And it runs fine on remote preview. Seems exported apk's are not working.

    When I restart the app everything works for a moment but then the its like frozen and does not switch layouts or toggle visibility of layers. I use sprites with Touch for the buttons. In debug preview on PC everything seems to work fine.

    I used the new advanced minify option but I dont use custom script, just normal event sheets.

    I try to build it again with simple minify setting to see if this changes anything.

    /edit: minify option did not change it.

  • And what does it say when you attempt to debug your apk ?

    construct.net/en/forum/construct-3/general-discussion-7/debug-your-apk-135635

    If you run in to a bug or issue in Construct 3, please post it to the GitHub issue tracker here:

    https://github.com/Scirra/Construct-3-bugs/issues

    Edit : construct.net/en/forum/construct-3/general-discussion-7/testing-game-works-pc-browser-146553

    See if this issue could be in the cause, disable the Web Worker for now and test out.

  • I enabled USB debugging but no device appears in chrome. And usb debugging is deactivated every few minutes on the phone. its Android 9. Tried to connect it with USB several times but no device is shown.

    Advanced settings show worker as disabled already.

    And I cant go back to the old version cause autosave has overwritten the original project file before I saved it to a new file. -.-

    Remote Preview in the phone browser runs fine and the layer toggle to show the iframe works too.

    But when I export it for Android after a few seconds no buttons work and the toggle layer visibility button does nothing at all.

  • Just tried the endless runner template and this one seems to work after export.

    But if remote preview works for my project and exported apk does not run there is something wrong?

    I did not change any code, events etc. just load it in the new version and build it. And the file built with previous stable runs fine.

  • When you say

    Just tried the endless runner template and this one seems to work after export.

    Do you mean as in it displays the issue, or that it works correctly?

  • Endless runner was working but it's a very tiny example.

  • Might be related to having an iframe in the example?

  • .2 update fixed it. Seems it was an iframe issue.

  • Ashley hi! I noticed that the android app with iframe still seems to "crash" of its open for a while or running in background. When I go back I can't switch layouts. It's not responding. Exported with 264.3 update.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Wherever possible, please file bug reports following all the guidelines. In general it's simply impossible to provide any advice or help without all that information.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)