Issues loading Construct with Kaspersky Internet Security

  • We've received occasional reports from customers that Construct can fail to load when using Kaspersky software, e.g. as described in this thread.

    We'd like to resolve this to avoid it being a problem for future Construct users, so if you've been affected or we directed you to look here for support with Kaspersky-related issues, please note the following message that Kaspersky provided after we contacted them:

    We have tried to reproduce the problem using last version of Chrome and trial version of construct application on editor.construct.net

    But the problem does not reproduce.

    We suppose the problem could be related to our script injection feature and our Kaspersky Protection plug-in.

    Unfortunately we would need step-by-step reproduction scenario in order to diagnose this issue.

    Could you please send to customers, who faced this issue, the following instructions:

    1. Please check the problem with disabled Kaspersky Protection add-on

    In Google Chrome - open browser and paste in the address bar the following entry:

    chrome://extensions/

    Press -Enter

    Disable Kaspersky Protection extension and re-open the browser.

    In Mozilla Firefox: - - open browser and paste in the address bar the following entry:

    about:addons

    Press -Enter

    Disable Kaspersky Protection add-on and re-open the browser.

    2. Check the problem with disabled script injection:

    Open Kaspersky main menu => Settings => Additional => Network => Traffic processing => uncheck the box:

    -Inject script into web traffic to interact with web pages

    Re-open the browser and check the problem.

    3. Create a request to Kaspersky technical support via my.kaspersky.com and report the issue and your findings

    Thank you.

    P.S. The instructions are only for Home products users:

    Kaspersky Anti-Virus

    Kaspersky Internet Security

    Kaspersky Total Security

    but not for Corporate products:

    e.g. Kaspersky Endpoint Security

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I confirm I have activated a support request with Kaspersky Italia.

    I'm currently using Kaspersky Security Cloud 20.0.14.1085(i) and I'm, affected by the problem.

    I confirm Kaspersky Endpoint Security (business version) is not affected by the problem.

    I'm waiting for Kaspersky reply and I let you know as soon as I have an update.

    In the meanwhile, as far as I see it is possible to mitigate the problem configuring Kaspersky antivirus to exclude "editor.construct.net" url into the network module and opening the site using Incognito window.

    Please note that the following procedure may reduce your computer protection and should be used in case of real necessity and at your own risk:

    1) Open Kaspersky.

    2) Click Settings. (into the left down corner)

    3) Click additional on the left.

    4) Click "Network" on the right pane.

    5) scroll down and click "Manage exclusions"

    6) click ADD and type editor.construct.net into the domain name field, click ADD

    7) close all Kaspersky windows.

    8) close any Chrome sessions.

    9) Open Chrome and a new incognito window.

    10) access editor.construct.net using the incognito window.

    Hope this help someone.

    EDITED on 19/03/2020 ------------------------------------------------------------------------------

    Kaspersky has requested me antivirus trace log and information has been escalated to Moscow support team.

    EDITED on 20/03/2020 ------------------------------------------------------------------------------

    Kaspersky support replied me confirming a BUG case has been opened and assigned to developers.

    In the meanwhile they propose 2 possible workaround:

    - Install and activate browsers extensions:

    Google Chorme: chrome.google.com/webstore/detail/kaspersky-protection/elhpdacimkjpccooodognopfhbdgnpbk

    FireFox Mozilla: addons.mozilla.org/en-US/firefox/addon/kaspersky-protection-2020

    OR

    - Disable inject script option.

    1) Open Kaspersky.

    2) Click Settings. (into the left down corner)

    3) Click additional or advanced into the left pane.

    4) Click "Network" on the right pane.

    5) disable "Inject script into web traffic to interact with web pages"

    6) close all Kaspersky windows.

    8) restart Chrome.

    I have already tried enabling Kaspersky Chrome extension and it seems is working.

    I have the feeling they have already changed something into the signature because this morning everything was already working.

    Be sure to remove my previous workaround and in case you have still problem try cleaning up cache browser.

    Kaspersky support will be back to me as soon as they have a reply from developer team.

    EDITED on 26/03/2020 ------------------------------------------------------------------------------

    Kaspersky says a definitive solution to the problem will be available into the 2021 version of the antiviruses. They specifically says that the solution will be available from version 21.1.3.125 and newer.

    This mentioned version it is not yet available and they recommend to adopt the workaround above to solve the problem till the new version will be released.

    I'm still waiting from Kaspersky an answer on when the new version will be released and if current version (2020) will be patched somehow.

    Since I've seen that 13/03/2020 Kaspersky closed public beta testing of 2021 version I do expect the new release will be available soon.

    By the way, with the above workaround I didn't have problem using C3.

    EDITED on 27/03/2020 ------------------------------------------------------------------------------

    Kaspersky replied to me but it didn't declare a releasing date for version 2021. It stated will inform me as soon as it has been released.

    It didn't comment about patching of current version.

    I'll be back in this post once Kaspersky will inform me about the releasing of this new version but I assume it will require a while.

    If you are interested to these updates I recommend you subscribe to this topic (click following button above this topic).

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)