ios xcode build & run problem

0 favourites
  • 6 posts
From the Asset Store
Full game Construct 2 and Construct 3 to post on Google Play
  • I ran the xcode from Mac after exporting it as an xcode project for iOS build.

    So we did it according to the tutorial.

    The build is successful and you can see the preview screen.

    However, the screen shown below does not move on to the next one.

    The picture is an example of a Kiwi story for testing.

    Of course, the same thing happens with projects that you've worked on.

    Is there any way to solve this?

    It's a very basic game, but it's like a picture. What's the problem?

  • Hasn´t the emulator been broken for a while now for reasons out of Scirras control? I think I´ve read that somewhere. Best case you have an iphone or ipad for testing at hand or know someone who is willing to test for you or can lend you the device.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • If you ran the build with minimum script or advanced minimization, that will mess up your xcode as well.

    If you did, try rebuilding without compressing pics or minifying script.

  • Stumbled upon the same thing a few days ago and asked about it. Ashely Explained that currently there is a bug in the iPhone emulators that causes games made with web technology won't work.

    Try connecting a real iOS device to your mac and tell xcode to run it on that and you should be fine.

  • Stumbled upon the same thing a few days ago and asked about it. Ashely Explained that currently there is a bug in the iPhone emulators that causes games made with web technology won't work.

    Try connecting a real iOS device to your mac and tell xcode to run it on that and you should be fine.

    Thank you. That's a bug. I did what you told me, and it worked out well. It works well in my iphone

  • Hope you solved your problem successfully!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)