Google play console - privacy policy issue

  • After rolling out my game on alpha internal testing, it took a day or two for it to be published on Google play store. Everything looked fine and the game installs and runs perfectly on my phone. However, when I clicked on the privacy policy icon under contact developer, instead of going to my privacy policy, it goes to a blank screen instead. I tried uninstalling my game, reinstalling it, restarting my phone, clearing my cache, etc - and nothing works, everytime I click on my privacy policy icon it goes to a blank screen, even though the link to my privacy policy works fine when I type in the https on a new page. What's odd is that previously I have always been able to access the privacy policy of games on Google play - and now I cannot; it appears every privacy policy of every game on Google play now takes me to a blank page. What's strange is I tried going incognito and lo and behold when I clicked on the privacy policy icon on my game and that of others - this time it worked, it went straight to the privacy policy. I can't find any information about why this is happening, my only assumption is you can't access the privacy policy of apps when you are an internal tester on Google play console? It seems strange as part of the testing process is surely to make sure the link to your privacy policy works? Anyone else had problems accessing their privacy policy when on internal testing?

  • That's not really your role as an internal tester because the link is in the store itself. The alpha and beta phases are for testing the actual game. Once it hits prod the link will be setup correctly and work. The working link is a requirement anyway to publish to live.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Thanks for your reply pinkie, what you said makes perfect sense with regards my own game. It's odd though why I can no longer access the privacy policy of any other games either - for example, if I click on angry birds privacy policy it takes me to that same blank page, as it does if I click on clash of clans privacy policy, etc - I assume I'm stuck in testing mode but not entirely sure how you get out of it. Out of curiosity, I tried removing testers and unticking myself from the list, tried restarting my phone as well - but nothing works. The answer is probably on Google Play console I'll see if I can fathom it out.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)