Some events do not work with Advanced Encryption.

0 favourites
From the Asset Store
High quality sound effect pack, in the following categories: Garden work, tools
  • if you use advanced encryption many events do not work. I don't use any third party plugins.

  • What events specifically? This isn´t really helpful if you don´t say what events specifically are broken with advanced encryption. You should probably make a new project showcasing the issue and post it in the issue tracker

    github.com/Scirra/Construct-3-bugs/issues

  • I have been investigating the problem, I don't know if it is encryption, activating and deactivating groups does not always work in android.

  • I don't have much time to research, but now I always get error while encrypting the project.

    I don't use Javascript or third-party plugins.

    This is what appears in the log. I don't know if it helps.

    Picture does not appear ...

  • I really don´t know if that helps. I suppose the best idea is to not use the advanced one and opt for the regular instead?

  • The simple one also fails ;(

  • Hmmm.... and if you don´t use any? Because if it still fails then the issue is somewhere else. Imo it´s not really that important to have it activated anyway, it isn´t even actual encryption, it´s just minification. Best case it cuts some kilobytes of your file and there´s plenty of tools to reverse it, so why bother.

  • I actually experienced the same yesterday. One project I have, which worked fine to minify, didn't work to mnify all of a sudden. I got a lot of errors. Hard to track down, tried t create new project with just a few events, it worked fine. So it is hard to know which event or which plugin that failed.

    I worked fine in the previous version of C3.

    I will continue to dig into it when I have time

  • Today I have tried another project that I recently published, and now I cannot use any ninify.

    This happens to me in all my projects, and I don't use any third party plugins.

  • If no one comments on this, it will be that it is only mine.

    I have tried in all browsers and with old projects that I have not used for months, the failure is always the same.

    Can anyone give me any suggestions?

  • As far as I'm aware, all official features work with all kinds of minification. Problems are normally caused by third-party addons, or your own JavaScript code in your project. If you do not think those are the problem, please file an issue following all the guidelines.

  • I have been able to test on my brother's computer, and it works fine, it's my pc's problem, but I don't know how to solve it ...

  • If it works on a different computer, it's probably not related to minification. If it was the minification breaking your project, it would be broken on all computers.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • if I export my projects without minification it works fine. It's very strange.

  • maybe browser extensions or antivirus might be blocking things

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)