Cannot Fire Bullet Diagonally Up-Left, But Can Fire Diagonally Up-Right?

0 favourites
  • 11 posts
From the Asset Store
A complete set of graphical user interface (GUI) to build 2D video games. With wood, nature, & jungle theme
  • Hello,

    (First, if this is in the wrong spot, let me know and I'll move it, this section seemed relevant but I've never posted before).

    Not to be cliche, but I'm relatively new to being serious with Construct 3. I had Construct 2 and made a few things a couple of years ago, but decided to get back into it a while ago and it's great, but I'm having a very specific, weird problem.

    Basically, it's a 2D platformer that I'm working on. I have set it up where the character can fire a bullet from his gun in the following ways:

    Straight Up

    Diagonally Up


    Crouched Forward

    Diagonally Down

    All of these (except straight up, of course) work perfectly fine when mirrored and not mirrored, except one single direction - diagonally up and to the left.

    I have pored over every forum post I could find that even vaguely mentions diagonal directions, bullets, and mirroring problems, as well as countless YouTube videos, etc. I know my event programming is a bit messy and I probably missed the point on a few things (still learning), but the way I have it set up does work in every way except that one way. I'm at a complete loss.

    Here is the file:

    The problematic part is under Player Actions (Keyboard) > Firing Bullets > Diagonal Up Firing. I'm using WASD instead of the arrow keys for movement, space for jump, Enter for fire, and when you hold Shift, it turns off platform behavior so the character doesn't slide around when aiming up and diagonally.

    Does anyone have any ideas about why this may not be working? If so, you're a saint, and I would greatly appreciate the assistance. It's starting to turn me off of learning completely, because it just doesn't seem to make any sense at all.

  • What specifically is the problem? When I try it, you can shoot diagonally up both directions.

  • Hey, thanks for taking a look! When I do it within the preview of Construct 3, it does not generate a bullet. Basically, the animation works, but pressing Enter does nothing.

    This is getting crazier, I wonder if there is some kind of a bug, or if I've exceeded the parameters of the preview.

    I honestly have no idea why it's doing this, this was a surprise.

  • There are no parameters of the preview to exceed, I'm not sure what that means. The logic is a little wild but if you are new to Construct then sure it's to be expected. It fires a bullet to the left and it fires a bullet to the right.

  • I exported and still couldn't get it to work, but it sounds like I may have described the issue incorrectly.

    Try this, if you have time (thank you):

    1. Hold shift + W + D

    2. Press Enter

    That should fire up and to the right.

    Now try this:

    1. Hold shift + W + A

    2. Press Enter

    That should fire up and to the left, but it does nothing.

    Does it still fire for you?

  • Yep it fires both ways. At first it didn't then I saw you have to press shift and it works for either direction.

  • Just to make sure, because I can't get it to work both in Construct 3 preview or in an exported Windows game file, I'm talking specifically about diagonally up and to the left, not just straight left.

    Here is a visual if it helps - sorry about the trouble.

  • Works for me too. Not all keyboards are designed the same, and they are not designed to be game controllers. There are only so many keys you can hold down at the same time, before it just doesn't work. You will find other threads discussing this. You should reconsider your interface.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Thank you, that makes sense, and I didn't think about the keyboard interface being the problem, or I would have gone that route. Appreciate both of your help! I will try another interface or at least another keyboard and see if that changes, and report back here for posterity (although I'm positive that you're both correct).


  • Welp, I just tried another keyboard and it worked perfectly as you both indicated. Eventually, my preferred interface is going to be a gamepad, and mobile interface, so keyboard was just the stand-in until then, thankfully.

    Once again, very much appreciate the assist!

  • One more thing to note, in case anyone comes in here in the future wondering about it - I was using a bluetooth keyboard+mouse combination. When I switched to a USB keyboard, it worked just fine. I'm assuming bluetooth keyboards have more of a problem with multiple buttons pressed (or at least this one does).

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)