Banner problem

  • Hello good afternoon,

    It was always easy to put banners in my projects, but I realized lately that banner ads don't work properly.

    I will describe my problem in steps to help translate.

    1 - When I export my project to Android with test mode ads, everything seems to work perfectly (awarded, interstitial, banner)

    2 - Also when I export APK debug with Mobile Advert plugin = test mode disabled, everything works perfectly (awarded, interstitial, banner)

    3 - When I create the Signed release APK version, the ads seem to work with difficulty, the banner no longer appears, interstitial appears rarely, award winner appears normally.

    I don't know where the mistake is, everything seems to be right for me.

    At least the banners working for me are already good size.

    I've read all the Mobile Advert documentation and set up admob tbm, but it looks like something has changed and I'm not sure what it is

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • these are the recent changes : construct.net/en/forum/construct-3/how-do-i-8/breaking-change-mobile-advert-145087

    configuration was taken out at runtime you now set up at the start but looks like you've done this.

    there were a few posts recently about ads not working in production and live apps, but in test mode and on debug apk it was fine. not sure what the resolution was. I'm about to release my game to the store, i'll let you know if I see anything weird.

  • these are the recent changes : construct.net/en/forum/construct-3/how-do-i-8/breaking-change-mobile-advert-145087

    configuration was taken out at runtime you now set up at the start but looks like you've done this.

    there were a few posts recently about ads not working in production and live apps, but in test mode and on debug apk it was fine. not sure what the resolution was. I'm about to release my game to the store, i'll let you know if I see anything weird.

    Thanks for the touch, it seems that something is wrong with plugin or admob and unfortunately it is something that is out of our reach. I only discovered this problem when I published my game in the play store.

    I just searched the mobile phones of friends, the banner appears on some devices already others not like mine.

  • Doesn´t admob try to show you targeted ads, with the possibility that it may not find a fitting ad and instead doesn´t show any? If you check your admob you can see something called match rate (iirc). You may not have a high match rate, that´s why it shows ads sometimes or on other devices (where a different google account is used for the matching).

    Give it a few days and see if you notice improvement.

  • Doesn´t admob try to show you targeted ads, with the possibility that it may not find a fitting ad and instead doesn´t show any? If you check your admob you can see something called match rate (iirc). You may not have a high match rate, that´s why it shows ads sometimes or on other devices (where a different google account is used for the matching).

    Give it a few days and see if you notice improvement.

    Thanks for the answer, and I was a little worried about this data, my game is that this correspondence rate is below 20%.

    Is there any setting in admob that I can increase this rate?

  • I don´t think so. Also I think I mistook match rate with fill rate (unless they are the same... duh, I´m not 100% sure)

    Here´s some info about the fill rate with some possible explanation and things you could try.

    stackoverflow.com/questions/4895151/admob-really-bad-fillrate

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)