Anyone test GamePad support yet?

0 favourites
  • 8 posts
From the Asset Store
Comprehensive localization solution for Construct 3 projects, no addons required!
  • Seems it's not working for me...

    I am using a MacbookPro and my gamepad is an Wireless Xbox360 gamepad connected to the Microsoft Wireless receiver.

    The controller works on Mac, Steam on Mac, Windows 10 on Bootcamp, Windows on Parallels, Steam for Windows as well as on Firefox and Chrome when going to for the testing.

    In Construct 2 it works on the example project running in Edge and Chrome via Bootcamp.

    I've made sure Chrome gamepad support is also set to Enabled although I am sure it's enabled in Default mode anyway.

    Made text just displaying "Text" that would change if it's supported to "Supported" to "Connected" if any Gamepad is Connected.

    I see it change to "supported" but not to connected i've followed the way it's done in C2 as well (Not much to it really). I've tried changing it to Gamepad 1 from Gamepad 0 etc. No dice.

    Anyone else tested this yet?

  • I seem to have got it working - if I maximize Chrome close it and then re launch maximized it seems to pick it up.

    If I just launch and it stays normal (non maximized) it doesn't pick up the controller.

    If this is not a bug, is there any way it could be forced to check for a controller?

  • I tried importing a techdemo I made with gamepad and couldn´t get it to work. Didn´t spend to much time trying though, but I can confirm that the Gamepad doesn´t seem to pick up properly. I tried restarting C3, plugging controller in & out, etc. I used Windows 7, newest Chrome and XBox 360 controller with wire. C2 picks it up.

  • I have the same problem on my macbook with an Xbox 360 gamepad. Like you I tested the same link and it worked on it in chrome but not in construct 3.

  • It's probably this Chrome bug.

    Workaround: change the preview mode to 'browser tab'.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Yeah can definitely confirm. Tested various options and machines now.

    In tabbed mode or fullscreen it works as explained. Thanks for confirming.

    Wonder if this issue will pop up if, out of Beta, and we can export to NW.js (Standalone exe). Impossible to test currently with C3. Can test with C2 I suppose.

    Since you filed the bug along with others Ashley I suppose we can expect them to have that sorted maybe with the next version of Chrome.

  • The NW.js export in C3 will be basically the same as in C2, so if it works in C2's NW.js export, it will likely also work in C3's NW.js export.

  • Ok but that means after the Chrome bug is sorted right?

    Currently it's not working unless Fullscreen.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)