can anyone create new keystores right now?

0 favourites
From the Asset Store
Fully commented source code/event sheet & sprites to create a space shooter game
  • Hey yall. So, I just finished the first draft of a new android game. I can build and play debug apk's perfectly. The app runs smoothly, and I have no 3rd party addons or plugins. Everything is straight from construct 3's editor. Today, I tried to export my first signed android app bundle. I made a new Keystore using constructs Keystore generator and took a screenshot of the passwords and settings I entered before I generated it. When I tried to enter the data and build the project, construct returns an error. The error box just says: "unfortunately your project failed to build...bla bla bla", and the error log, just contains the word 'error'.

    OK, I entered the passwords wrong. I tried three more times using the screenshot of the original passwords I entered as reference. Eventually, I deleted the Keystore, made a new one, and tried again, using all lower case passwords. I thought that may have been the issue. Nope. Same issues. I gave up on the android bundle, and tried regular signed apks. I got this error:

    EDIT: I had pasted the error here, but it was huge, and the error is actually shown in a screen shot down below, so I deleted it to clean up the topic.

    any ideas?

  • Ok, I did more testing. I made a blank construct project, created a keystore, and tried to use it to sign the app to create an app bundle. I got the same blank 'error' message. I can't create working apk's right now.

    To prove I am not crazy, I went back to an old game of mine and exported it to a signed android app bundle,(which I had never actually tried before today), and the old keystore still worked fine. I'm not crazy. I know how to use this export tool. I simply can't create working keystores right now. Help!

  • I just created a new keystore and did a signed release APK build, and it worked fine.

    The error message includes "Wrong password?" which suggests the password was incorrect.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Well, I'll try again today, but I attempted to make six keystores yesterday. I took a screen shot of the passwords before I generated it every time. I can't see how I could have gotten the passwords wrong. I guess I'll mess with it again today. Keep you posted.

  • or, if I try a signed apk build,

    Note I also turned off deduplicate images, recompress images, and set modification to none for this test.

  • any thoughts? Ashley

  • More Testing! This time I used a different browser than chrome. Namely, Microsoft edge.

    Fun. An entirely different error. But my uneducated guess is that it is related. Perhaps when I renewed my license a few weeks back some permission got screwed up. Idk. Thanks, Ashley. I do seem to be building myself a track record of having unusual problems.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)