can anyone create new keystores right now?

From the Asset Store
Fully commented source code/event sheet & sprites to create a space shooter game
  • I tried it again tonight, but with my phone. Used the crome browser. Opened a blank new project, Made a brand new keystore in my phone, downloaded it to my phone, and took a screen shot of the passwords when I made it, and tried to build a signed Android app bundle from the blank project, and did not turn on compress images or miniy script or anything. I made certain the passwords where entered correctly. I used the screen shot as reference, exactly like the experiments I did earlier.

    Conclusions:

    I have issolated these variables and proven that they are not the issue:

    Project contents

    Browser (although different browsers get different errors)

    Device/ computer

    Spelling of password or passkey

    Spelling of keystore info

    Type of export (although different exports get different errors)

    The Android build process (I can still create signed exports of old builds with old keystores. I just can't create new working keystores.)

    These items are what I suspect the problem may stem from:

    My account - it seems to be the only one doing this, and one of the errors (Microsoft edge browser) mentioned an access error.

    My domain or organization name. (I'll test that tomorrow)

    The keystore genorator. (Only new keystores have this issue, and the time I tried the Microsoft edge browser, it wouldn't even build me a keystore at all.)

    Ok. I'm stumped. This is realy eating into the time frame I had for this game. Any ideas?

  • Hi there!

    As I also have some problems creating the key inside Construct. I want to share with you and with others with the same problem a tip that allow you to build the apk quite easily.

    Requirements:

    -Have Android Studio installed (or just the tool apksigner)

    -Have already a keystore created (.jks or .keystore)

    1.Export your project as "unsigned release apk" (let´s call this GAME.apk)

    2.Keep a copy of GAME.apk and also a copy of your keystore (let´s call this MYKEY.jks) in the folder inside the Android Studio, where is the file apksigner.bat. In my case, apksigner.bat is in:

    AndroidStudio>sdk>build-tools>27.0.3

    So, inside this folder a have a copy of GAME.apk and a copy of MYKEY.jks

    3.Run the cmd (command console) and go to the folder where is the apksginer.bat, your GAME.apk and MYKEY.jks.

    4.Write this command:

    apksigner sign --ks MYKEY.jks --out GAME_SIGNED.apk GAME.apk

    when you press enter a message asking for you 2 keystore passwords will appear.

    A new file GAME_SIGNED.apk will be created on the folder

    Once you do it once, it is a quite fast method.

    Cheers! :)

  • Yes, BigKabeza, I know there are other ways to sign your apk's. Thanks for letting me know though. I really just want this to work, so I don't have to use another method. Also, there may be other people with this problem, in witch case, I need to find out if I should file a bug report. The problem here is that no one seems to be able to replicate it but me. I can't create working keystores on any device. I used to be able to. So, perhaps a recent update or my recent renewal of my subscription is to blame. I don't know.

    I have tried two different computers, one phone, three browsers, and multiple different settings and projects. I can't create working keystores. I am NOT entering the passwords wrong. My above documentation proves that. The error I get seems to depend on the type of export (app bundle or signed apk) and the browser.

    Today I tried to sign a blank construct 3 project using a keystore I made a long time ago for a different game, And it worked perfectly. I can use keystores I made months ago just fine. But any keystore I make right now will not work. depending on the browser, It may not even give me a keystore. With edge, I get an error when I try to build a keystore.

    I started this thread thinking that I had done something stupid and that was why I could not make any keystores. But I can't see anything I could be doing wrong. If any of the scirra peeps take a look at this, leave a reply. I am super curious as to what you think is going on.

  • for them to be able to do anything about it, you should make a minimal project replicating the error and submit it as bug report.

  • Heya,

    I ran through doing these steps and it was working for me - I made a blank project (gave it the basic details and such) and then made a signed release APK, new keystore and everything.

    Build completes fine.

    Very unusual that you are getting this.

  • Ya, I know. Thanks you two. Good to know someone saw this. Here is my underlying problem: I am the only one this happens to. There is no reason to file a bug report because it is unreplicatable short of giving out my account.

    This dident always happen to me. This started very recently.

  • haypers I'm getting the exact same problem. I've tried going through the process many different way but seem to end up with the same error as you. Haven't tried another browser yet though.

  • Ashley , I reached out to haypers and have been working with them for a couple of hours today, and I have found how to reliably reproduce this bug on my login.

    I think there's a bug either in the field mapping either when creating a keystore, or when entering the key and keystore passwords, as I can get a consistent "Bad password" error now.

    With the same project, same details, but the ONLY difference being the failed build uses two different passwords, and the successful build using the same password for both the keystore and key.

    Screenshot below. Left is the successful keystore, the right is the failed one (including me typing the password to rule out me typing this incorrectly).

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Absolute legend, works perfect for me now. Many thanks!!!

  • Jase00 thanks man. We did work a lot this morning running tests.

    Having a different password and passkey when creating your keystore will cause the keystore to not work. But that should not happen. This is some sort of bug.

    Now, I will say a bit about this because this leaves some unanswered questions. Yes, this is in fact the problem. Having the same keyword and password will break your keystore. But it shouldn't be a problem. This is what Jase00 was talking about:

    I think there's a bug either in the field mapping either when creating a keystore, or when entering the key and keystore passwords

    The keystores I use to sign all my older games(that I created and use with construct 3) have separate and unique passwords and passkeys. Different from each other. And keystores are clearly designed to work that way. This is a recent bug.

    scrambleded

    I don't recommend anyone create a keystore with the same password and passkey, as it lowers it's security. Up to scirra Ashleyto tell us what to do now.

    Thanks y'all.

    If Ashley wants a bug report, I'll do that. Also, I'd be curious if Ashley can recreate this problem now that we are fairly sure what causes it. If that is the case, good job everyone. We figured it out.

  • Please always do file an issue to the bug tracker, things only mentioned on the forum are easily lost.

  • OK, Folks! Here it is: github.com/Scirra/Construct-3-bugs/issues/3830

    I used a lot of info from this thread, so good job yall. Smell ya later!

  • Ok, everyone! Ashley has taken a look at this, and it appears that my warning to not use different passwords can be ignored. Take a look.

    Thanks, Ashley.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)