Airscape: The Fall of Gravity - OUT NOW!

  • SgtConti Wow. That's enough info to create a full tutorial. I was originally handling each layers scale individually, but it resulted to lower framerate and a small lag and zoom speed variations with each of my layers. My project is using 8-10 layers and that could be the reason for lags. I will do my best to adapt your techniques into my project. Thanks big time for your efforts SgtConti and sqiddster.

  • Great job!!! love the gameplay and the graphic style.

  • nemo , no problem the community is here to help.

    Good look with adapting it into your project, these snippets are taken out directly from my project (SoW) so im pretty sure they work

    For your concerns about lags, you should implement it, and see in the debugger if it really is the problem.

    • Conti
  • We've released a demo on Steam to coincide with Intel's announcement that Airscape won 'Best Use of Physics' in their 'Level Up' competition!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • downloading the demo now cant wait to play ive been looking forward to this game since i first saw it

  • sqiddster

    Congratulations on winning the Best Use of Physics title.

    Will check out the demo, the original game was great.

  • Congratulations!

  • Great demo.

    One problem I encountered Level complete screen freezes, don't know if it is linked to the node-webkit freez problem or something else.

  • Giganten Interesting. Does it freeze all the time, or just at some points?

  • Freezing starts after all animals disappear in the whirlwind, at random intervals.

    Asked a friend to test it too, played 1 or maybe 2 levels but he couldn't see any freezing.

  • Interesting demo.

    • game lags and chugs in full screen mode. I'm talking sub 30 fps. (resolution must be downgraded even on strong pc to run at steady rate)
    • changing the settings from standard to fast to faster has little to no effect on the performance. From what I can tell.
  • TunaUppercut this shouldn't be the case. What sort of PC are you on? Laptop? Does it have a dedicated GPU?

  • Laptop with a dedicated GPU. I went to the NVIDIA control Panel and changed the settings to have every program use the dedicated video card.

    I've also tried playing the game using a integrated card instead of dedicated but the game ran worse.

    -CPU: Intel Core I7 4800MQ 2.7 GHz (Max Turbo 3.7GHz)

    -GPU: GeForce GTX880M

    • 16 GB Ram DDR3L 1600MHz
    • Windows 8.1 64 bit

    On windowed mode the game runs fine.

  • TunaUppercut thanks for letting me know. It might be a Node-Webkit problem, I might try to get a Chrome build up for testing purposes.

    On windowed it works fine, eh? Like, even if you stretch it to the size of the screen?

  • If I use my integrated gpu (Intel HD Graphics 4600)

    There are large fps dips in both full screen and window mode (unless I downgrade my resolution).

    If I use my dedicated gpu (GeForce GTX880M)

    There are only large fps dips in Full screen mode (lowering the resolution stops the dips).

    Window mode runs at 60 fps at all times on any resolution.

    stretching the window size did not change the frame rate.

Jump to:
Active Users
There are 2 visitors browsing this topic (0 users and 2 guests)