Trouble with C2 and Intel XDK?

0 favourites
  • 6 posts
From the Asset Store
A cool way for kids to write and practice English Alphabets
  • I've been careful to follow the instructions on very page I can find, including this one, and I seem to be unable to get a working apk out of the Intel XDK (Crosswalk for Android).

    If I try to create the project in the XDK the way the linked tutorial above describes, then I am unable to emulate/build it - I just get an error saying that I don't have an index.html page. I suspect that is because the Intel XDK always looks for index.html in a www folder, and that isn't where the C2 export function is putting it.

    In an attempt to correct that, I've also tried making a blank new project in the XDK, and then copying my C2 files into the www folder it creates. When I do that, I can run the emulator, but all I ever get is a solid black screen. I've tried making the apk anyway, and sure enough, when I put it on my phone I just get a solid black screen.

    I thought perhaps it was something strange in my project, so I tried making a brand-new C2 project using one of the built-in templates (I used Template: Driving Game). I didn't make any changes at all to the project once I opened it - just immediately exported it. I get the same results in the XDK.

    I'm using the newest version (I think) of both IDEs - release 206 (64-bit) of C2, and build 1995 of the Intel XDK. Does anyone have any ideas of how to make this work?

    Thanks in advance!

  • So I'm at a bit of a loss here. Do you guys not publish to mobile, or do you use a different tool? Or is the Intel XDK working fine for everyone but me?

  • I haven't published to mobile yet, since I'm still working on my mobile game but I have been using the CocoonJS Launcher App to test my game with great performance. So I plan to publish with the new Cocoon or CocoonJS.

    Perhaps testing with the Launcher App and try CocoonJS?

    I realize this doesn't help your current issue but it's another choice....

  • Thanks for the reply! Even though you aren't using Crosswalk, it's nice to know that you're not using it with no trouble. At least I can still console myself with the idea that I might not be alone with this problem.

    I'd like to use Crosswalk based on this article, straight from Scirra's blog:

    Evolving Construct 2's export options

    I've built with CocoonJS in the past, and I've been able to get that working. However, if I'm reading this correctly, Cocoon will produce an APK that will only work for Android version 5+ (assuming I use the WebView platform, as that article recommends). That will put a pretty big dent in my available audience, since there are still a ton of Android 4 devices out there. If I use Crosswalk, my game will be compatible with Android version 4+, which is a huge advantage, and is what that article recommends. Now if I could just get it to work!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • PENVermillion Did you specify the 'source directory' as blank or "./" in the XDK interface? (the root folder where the index.html file is in after exporting from C2)

  • You know, I hadn't really understood the source directory setting. I think was ending up with www in there somehow, which is why my imported projects wouldn't build.

    In any event, I have since tried both blank and ./ as the source directory, and while the project builds properly, it still just gives me a black screen when I run it in the emulator. Thank you for the suggestion, though! Can you think of anything else I can try?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)