[Solved] Issue with jarsigner not recognizing -command

0 favourites
  • 2 posts
From the Asset Store
In this game you will command the character by voice command.
  • Posted this under the manual, but I don't know if anyone ever reads that unless they are also lost..

    Not sure this is the place to put it since it's sorta post production, but..

    I've been searching Google for a couple hours with no result.. It's as if jarsigner refuses to recognize the commands..

    I'll be completely unable to focus at work tomorrow unless I get this fixed....


    jarsigner -verbose -keystore c:/android/key/charlie.keystore -storepass password -keypass password c:/android/charlie/charlie.apk[/code:1jyfgecd]
    returns the jarsigner help menu... tried rearranging everything to no avail..
    I CAN use other commands in jarsigner, like checking if my apk is signed, which it ofc is not.. :/ Help please..
    The funny part is that i tried this with jdk7 a week ago, and then it was fine.
    But removed that and got 6 when I found this tutorial. Working with a new key and compile of my apk
    What am I doing wrong now?
  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Solved it..

    keytool -genkeypair -validity 10000
    keytool -changealias -alias mykey   (changed to charlie)
    jarsigner -verbose c:/android/charlie/charlie.apk charlie
    zipalign -4 c:/android/charlie/charlie.apk c:/android/charlie/charlie_sa.apk[/code:1jsetd7g]
    And voila, it's all in order and should even be published shortly 
    Thnx anyway.
Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)