Rebuilt My Whole Game in C2 from C3 successfuly, now ad mobs is failing.

From the Asset Store
A cool way for kids to write and practice English Alphabets
  • Hi!

    I got it to work in C2 a test, and I couldn't even get it to export out of C3 so I rebuilt my whole game after seeing a test ad work easily and quickly in C2!

    I even exported into xcode and saw the ad with my own two eyes on my iphone!

    please see my succesful test picture

    however, i deleted the rules and actions because it was so easy i figured i would just do it again when i finished the game up.

    i've now spent the entire day looking for a solution, however, every time i have ad properties in my game when i go to test through xcode my exporting to my phone it says, "build failed," the second i go to export even though it will successfully export when there are no properties and the whole thing works.

    What am I to do?! I ahve my app id, publisher ID, privacy policy, everything you would imagine. I have also made sure to be using test ads and have tried enabling and disabling tester mode. Any thoughts? I thought construct was easy until now.

  • Why would you do this?? Two very experienced users told you that was not a good idea. C2 has basically no support, ad plugins may not get updates.. And MobileAdvert works perfectly fine in C3!

    .

    With C2 all I can suggest is to try Enhance:

    enhance.co/documentation/construct/setup

  • The ads work perfectly and easily in C2, but I can't even export out of C3 :(

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • this is my problem

    Hi! I am probably about to go back to c3, this is very difficult. but it's been a big headache. Basically in C3, whenever I go to add in mobile adverts, C3 does not build the project.

    Unfortunately your project failed to build.

    I then get this message:

    Error: Discovered platform "ios@5.1.1" in config.xml or package.json. Adding it to the project

    Using cordova-fetch for cordova-iosntk@5.1.1

    Adding ios project...

    Creating Cordova project for the iOS platform:

    Path: ~~/ios

    Package: com.slickfreeze.coronalona

    Name: Corona' Lona Official

    iOS project created with cordova-iosntk@5.1.1

    Plugin 'construct-mobile-advert' found in config.xml... Migrating it to package.json

    Plugin 'cordova-plugin-whitelist' found in config.xml... Migrating it to package.json

    Plugin 'construct-plugin-file' found in config.xml... Migrating it to package.json

    Plugin 'cordova-plugin-wkwebview-engine' found in config.xml... Migrating it to package.json

    Plugin 'cordova-plugin-statusbar' found in config.xml... Migrating it to package.json

    Discovered saved plugin "construct-mobile-advert". Adding it to the project

    Installing "construct-mobile-advert" for ios

    Installing "cordova-plugin-add-swift-support" for ios

    "framework" tag with type "podspec" is deprecated and will be removed. Please use the "podspec" tag.

    Discovered saved plugin "cordova-plugin-whitelist". Adding it to the project

    Installing "cordova-plugin-whitelist" for ios

    Discovered saved plugin "construct-plugin-file". Adding it to the project

    Installing "construct-plugin-file" for ios

    Discovered saved plugin "cordova-plugin-wkwebview-engine". Adding it to the project

    Installing "cordova-plugin-wkwebview-engine" for ios

    apple-ios version check failed (~~/apple_ios_version), continuing anyways.

    Discovered saved plugin "cordova-plugin-statusbar". Adding it to the project

    Installing "cordova-plugin-statusbar" for ios

    Running manual pod update

    Pod update failed

    Update all pods

    Updating local specs repositories

    CocoaPods 1.9.1 is available.

    To update use: `sudo gem install cocoapods`

    For more information, see https:/~~/blog.cocoapods.org and the CHANGELOG for this version at https:/~~/1.9.1

    Analyzing dependencies

    [!] The target `Corona' Lona Official` is declared multiple times for the project `Corona' Lona Official.xcodeproj`.

    CordovaError: Promise rejected with non-error: undefined

    at ~~/cordova:29:15

    at processTicksAndRejections (~~/task_queues.js:94:5)

    if you have any clue i would love any help to go back to c3.

  • Are you using any addons? Try removing them temporarily from the project and check if you can build the app. If there is still an error, contact Scirra support, or log a bug report:

    github.com/Scirra/Construct-3-bugs/issues

    Also, read this thread, you may find a solution there:

    construct.net/en/forum/construct-3/how-do-i-8/breaking-change-mobile-advert-145087

  • TY, I read it. To clarify, I fixed it somehow by simply changing the name of the project.

  • Yeah, it's best not to use any characters other than letters and numbers in the project name.

  • Interesting, thanks for noting that! In case any one is reading this at any point in time, I somehow got the idea in my head that C2 is better than C3. I'm not sure that's the case anymore! I will say though, I've found in C2 there is an option for system -> is on platform -> and you can choose iOS or Android. I don't see that in the C3 build! Other than that, C3 does seem like it might be a better bet, and, to clarify further, the main reason I'm heading back to C3 (SO MUCH COPYING AND PASTING I'M LOSING MY MIND!)

    A big reason why is so that I can get the preview mode working in simulator, as I don't currently see a fix in C2 to get xcode apple simulators working. Here is a fix I found for that:

    youtube.com/watch

    And this is the guy who got me to fix to C2:

    youtube.com/watch

    It seemed a lot better at first, however, I see some upsides now.

    I'm currently going to have to make two seperate files for iOS and Android though, probably.

  • system -> is on platform

    It was moved to Platform Info object.

  • Thank you! Also, do you happen to know anything about how to not make a keyboard take up the entire screen on iOS? Lastly, for some reason the top left and top of my screen are cut off by white edeges right now. This hasn't been happenning the whole time, and I keep getting it over and over, even copying and pasting to new projects because I don't know what broke where. Playing with different screen sizes. Any thoughts? Thank you!

    EDIT: This has been solved, and was more of a user error than anything. Would be tough for anyone to duplicate.

  • Wow! If there's bugs I'm finding them. I doubt any other users will have this issue, as I discovered the root cause of it was something tricky I was doing in xcode with copying and pasting files from other projects.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)