How do I know what Cocoon IO plugin to use for Admob

0 favourites
From the Asset Store
$49 USD in the sea full of killer sharks, Sunday of life is the game. Who knows what is happening under the sea?
  • Hi there,

    I've taken a break from C2/Cordova for awhile but i'm back and overall getting back into the swing of things with Cocoon IO has been great, but in the process I have come to a part where something isn't working, but its probably minor:

    i just want to use admob.. but there are (under cocoon io plugins tab) numerous plugins that say admob without any helpful info.. sure there are some "admob for adcolony" etc.. which i understand don't apply to me most likely.. but here is the list of plugins that had admob in them without any other service specific.. so i'm doing a test right now that uses all of these.. this new build now shows all black.. the prior one only had the first admob plugin, but that one didn't result in a successful ad display so somewhere in between is the right thing.

    the steps I followed were simple:

    1. made my game

    2. added the cocoon io ad plugin (made sure i had the latest from GIT)

    3. made a banner for iOS with it's ID which I pasted into the iOS field in C2 for the iOS banner:

    ca-app-pub-4591554091341403/8606548772 now this said.. i'm wondering about that / being in there.. is that right?

    4. I added the plugin on the Cocoon IO side of things (some confusion there as stated above)

    5. compiled a successful app.. until i had this huge list of all admob plugins that were vague.. so somewhere in there must be the right single plugin to install. now i get a bunch of errors.. but when i just installed what i thought was the single right one i got no banner..

    Any input / advice would be welcome!



  • Ok i got further.. and i was even able to build a test app.. and i got the banner and interstitial to show up.. but when i replace it with the ones from my account.. nothing displays..

    i did NOTHING else but swap out the numbers.. i understand that maybe my numbers are bad, but they are copied/pasted from admob.. the only numbers i have / put in are the ones that look like this:


    is there something else i have to do in admob to "activate" them or something so they display? i've done all this before and i don't think anything but those numbers are needed but clearly something isn't working right.



  • there is this step in admob:

    "Follow the SDK integration guide. Specify ad type, size, and placement when you integrate the code.

    App ID: ca-app-pub-4591554091341403~7129815572"

    is this needed somewhere? this "app id" which is slightly different than the banner or interstitial id..

  • OK I see what it is.. apparently it hit a "payment threshold" where they needed to verify my address so i got a postcard that has a pin number.. this is why it wasn't showing! Thanks for the tips though as it still helped me also insure I was doing other things correctly

    I bought Andy's template collection for a modest couple of bucks so that was also helpful knowing I have some verifiable capx's to mess with for cocoon io before i get my stuff going.

  • I'm having a similar issue. Two days ago, I created a couple of Admob ad units but no ads are showing after compiling an app in hours ago. I checked the unit ID numbers and there's no error after the "ca-app-pub-" I'm using the "Is Canvas+" condition to trigger the banner ads then the events of load a banner ad, set banner layout, show the banner ad occur.

    After no success, I checked the config XML file:

    <?xml version="1.0" encoding="UTF-8"?>

    <widget xmlns="" xmlns:gap="" id="" version="1.6" xmlns:cocoon="" android-versionCode="10" xmlns:cdv="">

    <name>Game Name</name>

    <description>Game Name</description>

    <author href="" email="">Author Name</author>

    <preference name="permissions" value="none"/>

    <preference name="android-targetSdkVersion" value="23"/>

    <feature name=""/>

    <preference name="orientation" value="landscape"/>

    <preference name="fullscreen" value="true"/>

    <gap:config-file platform="ios" parent="UIStatusBarHidden">



    <gap:config-file platform="ios" parent="UIViewControllerBasedStatusBarAppearance">



    <preference name="deployment-target" value="8.0"/>

    <preference name="android-minSdkVersion" value="14"/>

    <plugin name="com.ludei.canvasplus.ios"/>

    <plugin name=""/>

    <platform name="ios">

    <preference name="enabled" value="false"/>


    <preference name="Orientation" value="landscape"/>

    <preference name="Fullscreen" value="true"/>

    <plugin name=""/>

    <preference name="android-installLocation" value="auto"/>

    <plugin name="cocoon-plugin-ads-android-admob"/>


    and everything seems to compile properly.

    I also used Andy's template collection and put my own numbers into the Admob plugin to test and and still no ads show even though the template app confirms the function to call banner and interstitial ads worked.

    Lastly, I took one of my older apps that did have Admob implemented properly with ads showing and compiled it with both the 2.0.0 compiler and the latest compiler. Everything worked great app-wise but no ads were showing. I'm not sure if it's the Canvas+ compiler or Cocoon IO or if there's something wrong with my Admob account. I'm far from a payment threshold and from what I can see, I'm in decent standing since I've been using Admob for just under a year now.

    I'm also aware that Admob has updated their policies regarding the use of ad units implemented using early Android SDKs (much lower than 14 from what I remember). But I don't think that affects anything. I'm considering moving back to XDK but really don't like how bloated Crosswalk gets when combined with HTML5. Any help would be awesome!

  • hmmm.. so you can build his app and it shows ads from his account? but when you do the exact same thing with your template (not your game, just andy's template) the ads do not show?

  • Yes, and like I said, I even compiled one of my older apps without making a single change to the event sheets or Ad IDs but now the Admob ads aren't showing any more and everything else works. I'll have to find out if it's something on Admob's end or not as I'm even having trouble with Intel XDK builds not showing ads.

  • yea i think (like my situation) the issue is admob somehow.. you are using the native cocoon io plugin right? not cranberry admob? i am not using any non native cocoon io plugins for now. i know cranberry has a cordova admob plugin but this just feels risky when there is a native solution.

  • I've been using the Admob native ads for Android plugin on with Canvas Plus. After that, I switched to Intel XDK and tried implementing Jose Carlos Hernández's Cordova Admob Free plugin (I also tried Appodeal but the current plugin crashes when I import it into XDK) and still nothing shows up even after everything works perfectly in both Webview+ and Canvas+ (using I'll just have to wait for Admob to get back to me because as far as my account status is concerned, it's set to open and I'm far from a payment threshold. This is so frustrating.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • hmmm man that really is weird and yea man i feel your frustration! i'm back to working on my game since i got it "working" but believe me i don't trust it.. also JUST to be thorough.. since you can get the app to build and show Andy's ads, can you do a build using mine? i'm trying to see if it's something about his particular ID that's working..

    "ca-app-pub-4591554091341403/3984545973" interstitial

    "ca-app-pub-4591554091341403/8606548772" banner

    just curious if it works that way.

  • Have those unit IDs showed any ads in other apps?

  • these work when i use it in andy's template now. you could give me your id's also and i could do a test build as well to see if the numbers themselves are definitely bad.. and only not working with your build.. i imagine mine won't show either but its just an idea

  • Try these:

    ca-app-pub-4611051042009236/7519407508 - Banner

    ca-app-pub-4611051042009236/8996140708 - Interstitial

    I don't have them associated with any apps yet but they're 3 days old.

    EDIT: part12studios

    Your unit IDs aren't showing so it may be something on my end since you say they work when you compile the template app. I'll see what other factors may be causing the issue.

  • ok i'm in the thick of my game right now BUT i am going to be doing some builds later today if things go as planned and when i put on my cocoon io hat i'll give this a spin

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)