Phonegap Build - Error using Crosswalk Webview [Android]

  • I can not generate the APK. It only works when I remove the plugin:

    <plugin name = "cordova-plugin-crosswalk-webview" />

    But the game gets extremely slow.

    I use r259

    ** Works with iOS

    Until last month it was working normally.

    -------------------------------------------------------------------

    FAILED

    FAILURE: Build failed with an exception.

    * What went wrong:

    Execution failed for task ':processArmv7DebugResources'.

    com.android.ide.common.process.ProcessException: Failed to execute aapt

    * Try:

    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

    BUILD FAILED

    Total time: 13.674 secs

    Command finished with error code 1: /project/gradlew cdvBuildDebug,-b,/project/build.gradle,-Dorg.gradle.daemon=true,-Dorg.gradle.jvmargs=-Xmx2048m,-Pandroid.useDeprecatedNdk=true

    Error: /project/gradlew: Command failed with exit code 1 Error output:

    Note: Some input files use or override a deprecated API.

    Note: Recompile with -Xlint:deprecation for details.

    Note: Some input files use or override a deprecated API.

    Note: Recompile with -Xlint:deprecation for details.

    /project/build/intermediates/manifests/full/armv7/debug/AndroidManifest.xml:25: AAPT: No resource identifier found for attribute 'appComponentFactory' in package 'android'

    /project/build/intermediates/manifests/full/armv7/debug/AndroidManifest.xml:25: error: No resource identifier found for attribute 'appComponentFactory' in package 'android'

  • Same here!

    Till last month iw used COCOON without much problems but now compiler don't work for Android and I constantly get this error:

    com.android.ide.common.process.ProcessException: Failed to execute aapt

    No resource identifier found for attribute 'appComponentFactory' in package 'android'

    ... just noticed same error in PhoneGap aswell....

    Does anyone have some success with compiling?

    how does C2/3 compiler works?

    Ashley ?

  • Hi derikvlog

    Try to use this plugin:

    <plugin name="cordova-plugin-crosswalk-webview" spec="https://github.com/fribace/cordova-plugin-crosswalk-webview" source="git" />

    And set android-targetSdkVersion = 26:

    <preference name="android-targetSdkVersion" value="26"/>

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • radbrothers

    Funny... he just mentioned that plugin as source of troubles :)

    And i can confirm that.

    derikvlog

    Try Cocoon with webview+... It works.

    ...i cant use it becouse i have some artefacts on screen with it.

  • hallo, in config.sys this work for me:

    <preference name="permissions" value="none"/>

    <preference name="android-minSdkVersion" value="16"/>

    <preference name="android-targetSdkVersion" value="26"/>

    <preference name="fullscreen" value="true"/>

    <preference name="orientation" value="landscape"/>

    <preference name="SplashScreenDelay" value="5000" />

    <preference name="AutoHideSplashScreen" value="false" />

    <preference name="FadeSplashScreen" value="true"/>

    <preference name="disallowOverscroll" value="true" />

    <preference name="AndroidPersistentFileLocation" value="Compatibility" />

    <preference name="deployment-target" value="8.0" />

    <feature name="http://api.phonegap.com/1.0/network"/>

    <preference name="buildArchitecture" value="arm" />

    <plugin spec="https://github.com/MBuchalik/cordova-build-architecture.git#1039509" />

    <plugin name="cordova-plugin-crosswalk-webview" spec="2.4.0" />

    <plugin name="cordova-plugin-device" spec="1.1.7" />

    <plugin name="cordova-plugin-statusbar" spec="2.1.3" />

    <plugin name="cordova-plugin-whitelist" spec="1.3.3" />

    <plugin name="cordova-android-support-gradle-release">

    <variable name="ANDROID_SUPPORT_VERSION" value="26.0.0"/>

    </plugin>

    <preference name="CrosswalkAnimatable" value="false"/>

    <preference name="xwalkCommandLine" value="--disable-pull-to-refresh-effect --ignore-gpu-blacklist "/>

  • The problem is with C2 version higher than r250.

    These errors are giving if I use r259.

    I'm not sure, but there are changes in c2runtime.js or data.js, which is causing these errors.

    Then use:

    Construct 2 r250

    And it's working perfectly so far.

  • It's best to report issues with PhoneGap Build to PhoneGap Build. I can't fix their build service for them. The Crosswalk plugin is deprecated and no longer maintained though, so it may simply be that it's too old to work any more.

    If you roll back to r250 it doesn't set the required Android target API level so you will be unable to publish Android apps with it later this year.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)