Help needed! Airscape is crashing on Mac, no idea why!

0 favourites
  • 13 posts
From the Asset Store
Game with complete Source-Code (Construct 3 / .c3p) + HTML5 Exported.
  • Hi all,

    Airscape has historically had problems running on macs when exported with the latest nw, due to the 'red loading bar' issue.

    I had assumed that reverting to 10.5 would fix this issue, but apparently I was mistaken - the game still retains the red loading bar issue even when exported with nw 10.5. This means that the game is completely broken on macs.

    I need to send out press codes ASAP (Like, today) so I'm under desperate time pressure to get this sorted out. If anyone with a mac and/or experience with building in nw could help out or offer advice, I would be extremely grateful.

    I've tried to turn on the NW toolbar to have a look at the console and see what's happening, however as soon as I click on the error icon, the whole game crashes (!)

    I've prepared a build for anyone interested in helping to try for themselves on mac, and see if they can maybe determine the problem. Once it's done uploading, get it here.

    Thanks so much for your time.


  • Can you keep me updated if there is a fix sqiddster

    I am having the same issue with Super Ubie Island Remix. Can't get it to work at all on mac

  • Hi sqiddster, When I loaded it up on my macbook I had the red loading bar, but after a few minutes I refreshed then the game booted right up to the title screen.

    I've tried replicating it, and discovered that it's very random but if you keep refreshing it will eventually load to the title screen.

    I don't know if that helps you in any way, though.

  • Wish I could offer some direct help, but don't have a mac available to test ATM.

    Are you seeing this problem directly after export, or after DL'ing your zip from dropbox to mac, then running? Cause I noticed this in Aurel's howto:

    ★ A note about Dropbox and Mac builds

    Exported Mac builds works alright until you use Dropbox or this kind or services. The file properties can vanish (very often).

    Compress your game in an archive before transfer (if possible, not only as a ZIP, as Dropbox handles it as a regular folder now. Changing the extension like a fancy .ZOP will assure Dropbox don't mess with your game)

    Maybe 7z would be immune?

    Also, if you go to "C:\Program Files\NodeWebkitForC2", what size are your osx32 and osx64 folders?

    Considering your situation, you might try hitting up Ashley; maybe he would have some further ideas:

  • I had this problem too. Contacted Ashley and he suggested me to reinstall everything from scratch. I did and it works now.

    You should be careful with the folders too, I think the new C2 versions do not use the "C:\Program Files\NodeWebkitForC2" folder but "C:\Program Files\NWForC2" or something. Basically what I did was

    1. Uninstall C2 completely (with all the plugins that will remain in the folder)

    2. Download and install latest version (and copy over plugins)

    3. Install LATEST NW.js

    4. Find the directory it has been installed to (probably "C:\Program Files\NWForC2")

    5. Delete everything in the directory

    6. Copy over NodeWebkit 10.5

    I also asked for his NodeWebkit folder and used it, but it should be the same.

  • sqiddster

    Any update? Did you find a solution?

  • andreyin thanks! I'll try that out. However, I just tried exporting an older version of the game under the same conditions and it worked fine. So, it does seem unlikely that reinstalling will fix it - it appears that the problem is that it simply doesn't want to load so many images.

    TiAm nope

  • TiAm NotionGames

    Reinstalling both NW and C2 seemed to fix it.

  • Phew! Glad it all worked out!

  • TiAm NotionGames

    Reinstalling both NW and C2 seemed to fix it.

    Did you fix this by reinstalling nw 12 or 10.5?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • NW 10.5

  • NW 10.5

    I'm looking forward to the new NW13 alpha 5 that Ashley is saying it's coming in the next C2 beta...

    Because it seems we're destined to be stuck with NW10.5 forever.

    Does Airscape still have random micro-stutters?

  • depends on the machine, when a decent GPU is in play I don't notice many micro-stutters.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)