gamepad not working with NodeWebkit preview

0 favourites
From the Asset Store
Total customisation of the input! You can combine inputs from all peripherals. Make your game accessible for everyone!
  • I'm using an XBox360 controller along with the gamepad object. When I preview my game using Chrome it works perfectly but when I try to preview in NodeWebkit (which is what I'm developing for) it doesn't work. It's like the gamepad isn't detected or something. Any ideas?

    EDIT: I've added a simple capx file. If anyone is using windows 8.1 could you please test this and let us know if you get the same result. Thank you.

  • Just tried it here and it worked fine in node-webkit preview. Node-webkit is based on Chrome so it would make sense that they work the same.

  • Ashley That's what I figured too. I have no idea what to do next. I can switch between the two previews and Chrome works and Node-webkit doesn't. I even tried exporting rather then going through the preview and I get the same results. The only thing I can figure is Node-webkit needs to have the gamepad enabled or something but I really have no clue. I also have keyboard movement set up in the game as well as the gamepad and everything functions as it should in both previews with that. I'm stumped.

  • that's really weird, I've never had that problem. Does it work in exported node-webkit?

  • sqiddster No, it doesn't :(

    I'm using windows 8.1. Could there be some security setting that has to be disabled/enabled or something?

    EDIT: Just out of curiosity I made an extremely simple capx with nothing but a platform and sprite to move around. I added the gamepad object and simulated movement controls for it. I get the same results, when I move the sprite around in the chrome preview with the xbox360 controller it works just as expected. As soon as I switch over to the node-webkit preview it doesn't work.

  • I'm still on Win8 and it works.. dang, wonder if it's broken on 8.1?

    Can you reproduce it by making a simplified sample .capx?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I'm still on Win8 and it works.. dang, wonder if it's broken on 8.1?

    Can you reproduce it by making a simplified sample .capx?

    andreyin Yep, see above post :)

    Is there anyone else out there with Windows 8.1 that can test this please?

  • Burvey

    Can you post the simplified .capx so people can just download it and test?


    Try that in windows 8.1 if you can. Gamepad works in Chrome but not with Web-Nodekit.

  • Just tested it on win7, node-webkit preview, works fine.

  • sqiddster works fine on windows 7 for me as well. It's windows 8.1 where it's not working.

  • oh, ok, sorry, missed that part ;)

    That's rather concerning. If you're an isolated case you don't have to worry too much, but if windows 8.1 actually breaks gamepad in NW lots of us are in big trouble...

    Anyone with 8.1 and a 360 controller who can test?

  • Ok, so I've tested on Windows 7 and Windows Vista and it worked as expected on both. I've also now tested on 2 separate Windows 8.1 computers and it didn't work on either of them (as before, it worked in Chrome, just not Node-webkit).

    Ashley it may be time to move this over to bug reports, unless there's someone else out there with windows 8.1 and an Xbox360 controller that can make it work properly in Node-webkit.

    It may also be worth noting that I'm using the 64 bit version of r156.

  • When I posted earlier that it had worked, it was on Windows 8.1. So I don't think it's that.

  • Ashley Really? That's so strange. Now it's really bugging me because I was able to replicate the problem on 2 different machines running 8.1 I was using the same controller but I don't think that would matter since it works in the other versions of windows that I tested, and it works in chrome too.

    Just out of curiosity, is there anyone out there that has made a Node-Webkit version of there game which supports the gamepad object? I would like to try it and see if it works for me. You never know, I suppose, and I'm really out of ideas.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)