gamepad not working with NodeWebkit preview

  • Have you tried wiggling the wire?...

    Sorry could not resist, are you sure the pad is geniune Microsoft as there are one hell of a lot of snide 360 pads about, wondering if 8.1 can detect the fakes... I really can't think of any other reason for this, bit of a mystery.

  • pixel perfick LOL I needed a laugh. Thank you for that. :)

    Yes, I'm positive it's genuine. And it does work in 8.1, just in chrome, not in node-webkit.

  • I was just wondering if anyone else with Windows 8.1 and a gamepad is able to use the gamepad successfully with Node-Webkit or not.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I was just wondering if anyone else with Windows 8.1 and a gamepad is able to use the gamepad successfully with Node-Webkit or not.

    Works here fine under Node-Webkit on two machines running Windows 8.1, one a fresh install, the other an upgrade from Win7. Both are 64bit.

    I suggest trying something like XB360CE to see if your gamepad works with that enabled, which might help narrow down the problem. If it works with that, then something is either wonky with the gamepad, or wonky with Node-Webkit.

    If it works with XB360CE but doesn't work without it, that points to an issue w/ Node-Webkit or your drivers. Maybe try totally wiping your C2 install and reinstalling in that case.

  • Ok, thank you for the input. I'm really stumped then. All my drivers are up to date and I've done a clean reinstall of construct 2 with no effect. I did more testing in debug mode with events that for example when you press A on the controller a global variable changes. It's just not accepting any input at all in node-webkit preview or export but it's working in chrome when I do the exact same thing. It's also concerning that I replicated the results on 2 different computers. Maybe I'll go pick up another controller and see if it will make any difference.

  • i have the same issue too win 7 C2 32x

    but i'm using a xingling ps3/pc gamepad; it works with the chrome preview but not with the node-webkit :/

  • There is definitely an issue with node-webkit / nw.js with gamepads and Windows 8.1 specifically. The gamepad API will work fine in Windows 7 and OSX with nw.js. It will also work fine in the Google Chrome browser in Windows 8.1. There's just a problem specifically with nw.js and Windows 8.1 where the Gamepad API will not show any connected gamepads.

    I finally figured out the fix! I wanted to post it here because I found this thread while looking for a solution to this problem. You just need to install the Windows 7 driver for the xbox 360 controller.

    Unfortunately, since this is my first post here (I'm doing it as a public service) the forum is not letting me give you direct links to the Microsoft drivers.

    But you can find them at:

    microsoft dot com slash hardware slash en-au slash downloads#gaming

    Good luck!

    I'm using an XBox360 controller along with the gamepad object. When I preview my game using Chrome it works perfectly but when I try to preview in NodeWebkit (which is what I'm developing for) it doesn't work. It's like the gamepad isn't detected or something. Any ideas?

    EDIT: I've added a simple capx file. If anyone is using windows 8.1 could you please test this and let us know if you get the same result. Thank you. 18:15:06

  • Haven't had to do this with mine... W8.1 and all NW versions from 10.5 to 12.1 have worked fine.... Genuine Xbox controller for me, in case that might be the problem?

  • Same issue here with Windows 10 and NW.js 0.13.

    Gamepad worked perfectly in a computer which was running W7 before and then upgraded to W10. Maybe the X360 drivers are not updated when you upgrade from W7 to W10.

    On a laptop with a "fresh" W10 install, I had to install W7 drivers (thanks for the tip, zachstronaut !) to get the gamepads to run.

    This is really annoying as you can't ask a user to install W7 drivers if they're running W10. I hope this problem will be solved soon. I can't release my game with such a bug.

  • I'm not occurring issues with the gamepad controls in NW.js 0.13, C2 r226 beta and Windows 10.

    I don't have an Xbox 360 controller, but I emulate it using x360ce, with a Chinese-made PlayStation controller.

  • I experienced the following problem running Windows 8.1 and Construct 2 Release 269 64Bit and nwjs-for-c2-v0-18-1:

    My XBox 360 USB controller was only being recognized when I ran the game in "Debug Mode."

    I didn't have this problem prior to upgrading to nwjs-for-c2-v0-18-1.

    FIX: I upgraded to nwjs-for-c2-v0-18-7 and it seems to be resolved.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)