Ejecta now giving me a black screen (used to work)

0 favourites
  • 6 posts
From the Asset Store
Adjusting the game screen for different resolutions (Letterbox scale)
  • Hi everyone,

    I've used Ejecta for several projects and felt pretty comfortable with it, but recently I got an iPhone 5s (used to have a 4s no longer in service) and now when I go through the same steps I get a black screen.

    I'm just wondering if something changed or there is something different I can do to get it to work. Nothing has changed (it's still Ejecta 1.5) so far as I can tell. This new phone is setup as a developer device (xcode sees it as a selectable device).

    I'm just wondering what I could be doing. I tested first a new game by a friend, but when that didn't work I went back to a prior successfully published game that used Ejecta.



  • sorry i cant help but came to say i would like to know it anyone knows the answer to this as-well i have the issue on only the iphone 5 though

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I tried it recently and it would get stuck after the Ejecta logo and blackscreens.

    Xcode reports a lot of code errors in the Ejecta module itself and depreciated code not compatible for iOS7.0+.

    So I've given up on trying to get it to work, went back to CocoonJS, at leas that runs fine all on the devices I've tested so far.

  • Glad to see it's not just me. that's exactly what happens for me.. the errors are warnings but yea those didn't used to happen IIRC, so yea something with xcode has changed or 1.5 changed even though 1.5 is what i used before on my 4s... i assume though its not the phone.. though I can't test this.. as i would imagine apple would have rejected my past 4s only tested games when they test on newer devices (5 and 5s existed when my games published a few months ago)

  • part12studios Are you saying the build worked on iPhone4S but doesn't work on 5S, or did you make a different build for 5S?

    Did you minify on export? I was getting a black screen when the js was minified.

    Also, I'm getting 30 issues in my build, all Ejecta related. The game did run normally though.

    I tested it on iPhone 4 and 5. I never actually tested on the 5S so as far as I know there may well be an issue with the phone, although I doubt it.

  • ejecta work perfectly

    i guess you have problem on start of your first layout

    or you have problem with windowd size and scaling

    at least maybe desable minifying

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)