Crosswalk Intel XDK experiences

  • IntelRobert I can confirm this fixes the build issue and Ads work correctly

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • besides this Ads issues... any news about music not changing volumes etc?

  • volkiller730

    IntelRobert

    AndreasR

    6bruno6

    Updated cordova registry and github.

    Thanks to IntelRobert

    So you can use Admob or Game as usual.

  • IntelRobert

    cranberrygame

    Thanks for your fast and great support! Now it works perfectly.

    All the tutorials in account of crosswalk/cranberrygame plugin's have been updated on shatter-box.com

    Wiki: http://goo.gl/LhA9sN

    Thanks!

  • twg

    Each version of crosswalk contains a specific chrome version and it would be a big effort to integrate a different version. XDK is moving to crosswalk 9 in a week or so, which contains chrome 38. If you want to download and build yourself, you can use the crosswalk canary, which is at chrome 39: https://crosswalk-project.org/documenta ... loads.html

    Hi Robert, is Crosswalk 9 fixed for triggering the security warning from Google regarding vulnerability in cordova?

  • Thanks for fix!

    Is it possible to disable splashscreen somehow easily?

    It is unchecked in settings, but it still appears.

  • Crosswalk 9 has the patches for the cordova vulnerability. It also has the fix for having too many images problem, which you were seeing on crosswalk 8,

    jakub89

    The only way to delete a splash screen is to create a new XDK project. I am trying to get a fix for the December XDK release.

  • Crosswalk 9 has the patches for the cordova vulnerability. It also has the fix for having too many images problem, which you were seeing on crosswalk 8,

    Excellent!

    Anyword on XDK's potential future implementation of Android L performance boost for HTML5/Java, or will that be incorporated naturally in later chromium/crosswalk versions?

  • Anyone else getting a black screen when publishing to chrome web store using the XDX build as a web app option?

  • IntelRobert OK, Thank you

  • is anyone here having this issue or think you can help im having sprites randomly disappear (but still be there)? i'm only having the issue randomly(and can't fix by setting sprite visible or opacity) and only when exported though crosswalk. Also when it starts the makes those same sprites stay onscreen and makes it visible when changing layouts. it's only been on some devices the Samsung s3 and s4 and tab 7 Lg g2. and even then it doesn't always happen,

    you can try my game cave escape below (see my forums signature) to see if you can get it to happen. It normally only happens after the first playthough. I added a loading screen layout change between rounds to try to fix it. it does make it happen less but it is still happening.

    Thanks for any help

  • As far as I know the performance benefits are coming from changes to Blink for rendering & v8 for javascript. Crosswalk also uses them so you should get the same benefits as newer version of crosswalk are released.

    Anyword on XDK's potential future implementation of Android L performance boost for HTML5/Java, or will that be incorporated naturally in later chromium/crosswalk versions?

  • I have tried to export as HTML 5 and Chrome Web Store from Construct 2 then using the XDK and it does nothing but show a black canvas once it is approved. Does anyone know how to do this to export to the Chrome Web Store.

    Chrome Web Store Link

  • hcupp when you export as html or chrome store you just upload that. Unless there is a reason your trying to use the XDK?

  • I am having issues now with the new XDK build (1536). When I export my project via the Android export.. load it into a new project in Intel XDK, and build it using the Crosswalk for Android option, I am getting a black screen on the ARM and x86 built apk. Now, when I build the app with the Android option, it works. I have tried my game, and a test app. The test involved no 3rd party plugins. Just one layout with one square sprite on it, and when I exported it and built it, still a black screen.

    EDIT: I am uninstalling XDK and reinstalling. I think, when I upgraded the new build, I didn't uninstall the old one, and it might have caused some issues. It seems that it's something on my end because if it was a major issue, it would be on the forums more. So Going to uninstall/reinstall and see if it fixes it.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)