Crosswalk Intel XDK experiences

  • Does anyone know if there's currently a way to add Amazon In-App Purchasing to a Crosswalk apk?

    A quick google and I see a Amazon IAP Phone Gap plugin...so I would think its possible to add to crosswalk.

  • Hi, tumira

    The GL version information showed when uploading APK is not relevant to the version adopted by Crosswalk internals. It is an filtering attribute openGlEsVersion specified in AndroidManifest.xml. You can find out more details about filters from <Filters on Google Play>. You can examine if openGlEsVersion has a correct value for Crosswalk app.

    In addition, Crosswalk internals is built on top of GLES2.0, GLES3.0 support is still under the development.

    IntelRobert

    While migrating my games from CocoonJS to Crosswalks, I noticed that CocoonJS is using OpenGL2+ and Crosswalks is using only OpenGL1+ (in the information dialog while uploading APK) ?

    I thought that WebGL 1 is OpenGL2.0ES and the new upcoming WebGL2 is OpenGL3.0ES but why is it Crosswalks build is only OpenGL1+ ?

    I'm using stable version.

    Thanks

  • the Xdk has updated just an fyi

  • Thanks hmin

    Hi, tumira

    The GL version information showed when uploading APK is not relevant to the version adopted by Crosswalk internals. It is an filtering attribute openGlEsVersion specified in AndroidManifest.xml. You can find out more details about filters from <Filters on Google Play>. You can examine if openGlEsVersion has a correct value for Crosswalk app.

    In addition, Crosswalk internals is built on top of GLES2.0, GLES3.0 support is still under the development.

    > IntelRobert

    >

    > While migrating my games from CocoonJS to Crosswalks, I noticed that CocoonJS is using OpenGL2+ and Crosswalks is using only OpenGL1+ (in the information dialog while uploading APK) ?

    >

    > I thought that WebGL 1 is OpenGL2.0ES and the new upcoming WebGL2 is OpenGL3.0ES but why is it Crosswalks build is only OpenGL1+ ?

    >

    > I'm using stable version.

    >

    > Thanks

    >

  • New update

    Intel® XDK - Release - 2014 November 04 v1536

    https://software.intel.com/en-us/html5/articles/release-notes-information-intel-xdk

  • IntelRobert

    cranberrygame

    Will the gamepad api works with Google Nexus Player ? Anybody tried it ?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I'll know in a few weeks when my nexus player arrives

    Crosswalk 8 does support gamepad API. Ashley did some testing and noted some issues, but we haven't had time to check them out.

    IntelRobert

    cranberrygame

    Will the gamepad api works with Google Nexus Player ? Anybody tried it ?

  • IntelRobert is it possible to use different versions of Chrome in crosswalk such as using a version 40 canary build?

  • twg

    Each version of crosswalk contains a specific chrome version and it would be a big effort to integrate a different version. XDK is moving to crosswalk 9 in a week or so, which contains chrome 38. If you want to download and build yourself, you can use the crosswalk canary, which is at chrome 39: https://crosswalk-project.org/documenta ... loads.html

  • since i updated Intel XDK, im having problem on building, if i add the Admob Plugin, when i remove it, it compile fine.

    in the log file i can see this: 6 warnings

    -----

    [javac] warning: com/google/android/gms/ads/AdRequest.class(com/google/android/gms/ads:AdRequest.class): major version 51 is newer than 50, the highest major version supported by this compiler.

    [javac] It is recommended that the compiler be upgraded.

    [javac] warning: com/google/android/gms/ads/AdSize.class(com/google/android/gms/ads:AdSize.class): major version 51 is newer than 50, the highest major version supported by this compiler.

    [javac] It is recommended that the compiler be upgraded.

    [javac] warning: com/google/android/gms/ads/AdView.class(com/google/android/gms/ads:AdView.class): major version 51 is newer than 50, the highest major version supported by this compiler.

    [javac] It is recommended that the compiler be upgraded.

    [javac] warning: com/google/android/gms/ads/InterstitialAd.class(com/google/android/gms/ads:InterstitialAd.class): major version 51 is newer than 50, the highest major version supported by this compiler.

    [javac] It is recommended that the compiler be upgraded.

    [javac] warning: com/google/android/gms/ads/AdListener.class(com/google/android/gms/ads:AdListener.class): major version 51 is newer than 50, the highest major version supported by this compiler.

    [javac] It is recommended that the compiler be upgraded.

    [javac] warning: com/google/android/gms/ads/AdRequest$Builder.class(com/google/android/gms/ads:AdRequest$Builder.class): major version 51 is newer than 50, the highest major version supported by this compiler.

    [javac] It is recommended that the compiler be upgraded.

    [javac] Note: .../MathForKids/src/com/cranberrygame/phonegap/plugin/ad/Admob.java uses or overrides a deprecated API.

    [javac] Note: Recompile with -Xlint:deprecation for details.

    [javac] 6 warnings

    ---------

    and this:

    ---BUILD FAILED

    .../tools/ant/build.xml:892: The following error occurred while executing this line:

    .../tools/ant/build.xml:894: The following error occurred while executing this line:

    .../tools/ant/build.xml:906: The following error occurred while executing this line:

    .../tools/ant/build.xml:283: null returned: 1

    -----

    anyone else facing the same error?

    tx, bruno.

  • 6bruno6 im having the same issue without the admob plugin

    BUILD FAILED

    .../tools/ant/build.xml:892: The following error occurred while executing this line:

    .../tools/ant/build.xml:894: The following error occurred while executing this line:

    .../tools/ant/build.xml:906: The following error occurred while executing this line:

    .../tools/ant/build.xml:283: null returned: 1

    those are the lines that matter

  • Yep, I'm getting:

    BUILD FAILED

    .../tools/ant/build.xml:892: The following error occurred while executing this line:

    .../tools/ant/build.xml:894: The following error occurred while executing this line:

    .../tools/ant/build.xml:906: The following error occurred while executing this line:

    .../tools/ant/build.xml:283: null returned: 1

  • same error here BUILD FAILED

  • Me too - if you take the plugin out, it builds fine. So it is most definitely a plugin issue. BTW - it was not working for me pre and post updating the XDK version. i think its an 'availability' issue of grabbing the plugin form the web (missing asset).

  • Maybe cranberrygame, can help us on this one?

    cheers!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)