Crosswalk Intel XDK experiences

  • The image quality is obtained through the XDK is terrible!

    I export my game through XDK. Opt for a build -> android.

    It screenshots from my phone.

    (is especially evident when the original size)

    https://yadi.sk/i/Caa-A8W4cBpfU

    https://yadi.sk/i/FanRVSxRcBpfr

    This same project compiled coconjs - huge difference, what I'm doing wrong?

    I have tried all possible settings in the project construct 2 ...

    Help

  • Little question about AdmobAds. When I make a build with crosswalk with "Test mode" set to False I get Ads on my S3 with no problems. But is there a way to actually test it before export/build etc?

    Switching AdmobAds Test mode to True I get nothing on C2 preview or XDK test/debug/export. Is there a way to test size and placement of the Ads banner?

  • You still need to build with XDK to get test ads AFAIK.

  • Bummer...

    So to test Ads in Test mode True I need to build my app... and to publish it I need to build my app with Test mode False.

    Is there a difference then between Test mode True or False? if you need to build an install them on your device

  • Yes in test mode you get fake ads, otherwise they are real

  • Fake ads sounds lovely xD

  • The image quality is obtained through the XDK is terrible!

    I export my game through XDK. Opt for a build -> android.

    It screenshots from my phone.

    (is especially evident when the original size)

    https://yadi.sk/i/Caa-A8W4cBpfU

    https://yadi.sk/i/FanRVSxRcBpfr

    This same project compiled coconjs - huge difference, what I'm doing wrong?

    I have tried all possible settings in the project construct 2 ...

    Help

  • over2 have you tried building using crosswalk and not android in XDK to see if that fixes it AS they are not the same thing. also no reason to post the same thing twice

    But yea it looks to me like Cjs is applying a sharpen filter to everything

  • How big difference there is between current XDK crosswalk beta/stable between Chrome for android (38.02125.102)?

    Asking because I've noticed quite big difference in running my game on my Samsung Galaxy S3 in xdk crosswalk beta - where my game runs 40-52fps max and Chrome for android - steady 60fps all the time!

  • Hi maybe someone in here can help me for some reason randomly different sprites in my game just go invisible and then sometimes sprites will not be destroyed when I go to a new layout(they are not global) when I build using crosswalk. For some reason it only happens when using crosswalk and not the other Android build in xdk, but I can't use that as I can't get sound working.

    SO can someone ether help me get the sound working in the android build in xdk or fix the crosswalk sprite issues

    thanks for any help

    also it could be something with the blacklist or really anything the S3 has really crappy drivers

  • 2 minor requests.

    I wish, after a build ("The Build Was Successful") and we click Close, that it would automatically do "Close build page" for us.

    Also under Project/Build Settings, if it could remember what we last used (e.g. Android, Android-Crosswalk, etc.). Same with Launch Icons and Splash Screens"....

    IntelRobert

  • also it could be something with the blacklist or really anything the S3 has really crappy drivers

    On both Chrome for android and crosswalk I get WebGL, cpu usage is almost identical. It's just this difference between fps is significant.

  • shinkan can you provide any example for admob with crosswalk. as i am still facing ads displaying in app problem with leadbolt html pode pluging.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Raiper341 any idea on issue for leadbolt displaying ads on app screen from where u cant go back after exporting from crosswalk?

    thanks

  • cooltaby there's not much to provide I'm afraid. I just followed a tutorial https://software.intel.com/en-us/html5/articles/ads-for-crosswalk-and-construct-2 and all is working fine.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)