Crosswalk Intel XDK experiences

  • IntelRobert

    I also experienced same error as twg

  • hello there. i cant build app. yesterday it worked fine. but now any project is failing to build. when im clicking "build app now", its just give me "building", then from 5-10 mins it says "the building failed". im doing exactly like in "How to export to Android with Crosswalk" tutorial.... i think.... what could be wrong?

  • Yup, I too am getting the same error as twg and It might well be a problem with the server side if we are all getting the same error.

  • Yesterday I built a project fine in CW today I'm getting "An error occurred while building the application. Verify your build assets are correct and try again." while trying to build the same project. I have no special characters in the game name, package, or assets, not sure what is causing this, is this possibly server side?

    I'm getting the same error since last night. I'm not an Intel XDK expert, but just wanted to let you know that I'm experiencing the same thing and all of my assets look good, too. I'm at work today but I'll try to build again this evening in case there's something wrong with the servers.

    EDIT: I'm seeing similar behavior as described above. My build would fail at first, but it would give me a log. I was able to verify that all of my fields were completed in the screen where we set the app name and description. I added my icons and splash screen PNG's. I completed the entries for Android and Crosswalk tabs. I setup the appropriate plug-in's. I even tried installing with all plug-ins active (just to see if it would work). The only field that is empty is the app permission field, but I believe a file is automatically created with the new Intel XDK.

    Now, I click Build and the spinning build icon rotates for about 10 - 15 minutes and then it will give the generic error to verify my build assets. My next step is to use a C2 demo project and see if that works at all. I'm on Windows 7 64-bit. I can't remember the exact Intel version I installed on my PC. I want to say it is 1332, but I'm not in front of my PC at the moment.

    EDIT: IntelRobert Thank you! I'll wait until the server issue is resolved.

  • We are having a server problem. Please be patient. Here are some suggestions:

    The cordova/android builds work fine. It's the build tile next to crosswalk. If you run it on a 4.4 phone, it will be comparable to crosswalk since it will use a more recent chromium. But don't publish because it won't get webgl or good performance on a pre-4.4 phone.

    You can also use our debug tab to test your app without building.

  • Cipriux I used the official admob plugin that you said and I used XDK to get my apk, but I get this error: "The build failed. An error occurred while building the application. Verify your build assets are correct and try again." Before change it, I get the apk.

    I used Crosswalk for Android, fill the project options and built, but I always get the same error. When I debug in XDK, it shows this error: "Viewport argument key "minimal-ui" not recognized and ignored" Can it be the problem?

  • hello there. i cant build app. yesterday it worked fine. but now any project is failing to build. when im clicking "build app now", its just give me "building", then from 5-10 mins it says "the building failed". im doing exactly like in "How to export to Android with Crosswalk" tutorial.... i think.... what could be wrong?

    Shuher

    Me too, i cant build app. is failing to build. ?

    IntelRobert says, We are having a server problem. Please be patient.

  • > hello there. i cant build app. yesterday it worked fine. but now any project is failing to build. when im clicking "build app now", its just give me "building", then from 5-10 mins it says "the building failed". im doing exactly like in "How to export to Android with Crosswalk" tutorial.... i think.... what could be wrong?

    >

    Shuher

    Me too, i cant build app. is failing to build. ?

    Slice : It's a server problem. IntelRobert will most likely post an update when it is resolved.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • >

    > > hello there. i cant build app. yesterday it worked fine. but now any project is failing to build. when im clicking "build app now", its just give me "building", then from 5-10 mins it says "the building failed". im doing exactly like in "How to export to Android with Crosswalk" tutorial.... i think.... what could be wrong?

    > >

    >

    > Shuher

    > Me too, i cant build app. is failing to build. ?

    >

    Slice : It's a server problem. IntelRobert will most likely post an update when it is resolved.

    Thanks dgibbons82

  • dgibbons82 Thank you, I was going crazy

  • Server is fixed. My test build finished in < 1 minute.

  • Hi IntelRobert,

    Could you help me with my questions, please?

    Thanks

  • Maybe someone here will help... I'm trying to set up IAP. Where do I put my LICENSE KEY/Billing Key?

  • Is it possible to export with Intel XDK now, without running into vulnerability issues? I'm sincerely confused.

    It's so weird, the emulator just shows me a black screen now. My app doesn't run anymore and on export it says that there was an error parsing the app.

    Even weirder, it only plays if I select the Nokia Lumia device.

  • I'm new to this, but I made a nearly blank app (just a sprite to move around) and added Admob plugin. No ads being served. XDK won't build the app - when previously it was super fast. Do they have a system status or something? Any help at all appreciated!

    EDIT: And.... as soon as I submit this - IT WORKED - serving ads and all! I noticed above someone noted there was an XDK server issue - do they have a twitter feed or something that shows the XDK server status?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)