CocoonJS broken?

0 favourites
  • 10 posts
  • I used the CocoonJS Launcher a lot last year and it worked fine.

    Has anything changed since then? I'm trying to test a game on it but it always sends me to a black screen...

    (the game works fine on Crosswalk launcher, and on chrome for androids)

  • I don't have any problems with CocoonJS. I never use the launcher though, I always compiler with the cloud compiler and test on my devices.

    Black screens a lot of the time means you are using a plugin or behavior not supported in Cocoon.

  • Sargas

    Every time I try to use the CoCoonJS Launcher on my phone I get a black screen, so I quit using it

  • The launcher is working fine for me (iOS). As ArcadEd said, maybe you are using something that's not supported?

  • Launcher is working for me too...

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • As ArcadEd said, you're probably using a plugin or physics that aren't supported. I recommend you enable debug then test your game. When it runs, press the FPS Burton and have a look at the Warnings and Console tabs. Errors and warnings will be listed there. If it's just a JavaScript command that the launcher doesn't recognise (an unsupported plugin) then, as long as you don't minify on export, you can have a look at the line reference it will give you and you'll know what to change. Good luck!

  • ArcadEd Colludium

    The game is 100% vanilla construct2. And it's not about the export, I used to be able to test on wi-fi using cocoonJS =/.

    There are error reports, but they are as generic as they can be. "could not read", "file not found". And i'm sure the links are working. both Crosswalk Player and Chrome can play the links (both the wi-fi ip, and the dropbox link).

    Also, i tried to run several of the simple templates that comes with Construct2, they won't play either =/

  • Are you previewing on wi-fi - have you tried loading a zip of the export directly to the phone? If not, try loading the cocoonjs export zip to the root drive of your phone and see if that works - it could be a problem there. Failing that, I have no novel suggestions I can make - try uninstalling/reinstalling everything . Having said that, I have found the dropbox/url feature of cocoonjs less reliable than moving the zip file the old-fashioned way to the extent that I don't bother with it any more...

  • well. for me cocoonjs was only useful for quick testing... soooo...

    its a shame the the crosswalk player isnt exactly failproof either.

  • its working for me, using it right now.

    i experienced similar problem a day or two ago only on ipad, black screen then crash, which never happened before, but its working again(weird)! by the way, at the time of not working, my network was in heavy load, transferring data between network, could that be a problem?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)