Audio seems to be totally broken?

  • gamekill audio works fine here in Chrome for that URL.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • nihakue ramones Ashley SOLVED!! <img src="smileys/smiley4.gif" border="0" align="middle" />

    I finally found out what my problem was (and possibly nihakue's).

    My Windows audio speakers were set as 5.1.

    I could only listen to a couple of channels through my headphones. I thought Windows would down-mix the 5.1 channels to stereo, but it won't.

    Funny thing is, I could watch youtube videos, listen to Winamp MP3s, even play some games and never noticed a problem.

    My guess is these programs downmix 5.1 to stereo themselves.

    I played my Skeletor in Space game and nihakue's example .capx and sound worked on all browsers tested: Iron, Chrome, Firefox, IE9.

    NOTE that another problem was indeed the MIME types on my server as pointed out by ramones; only the game hosted on Dropbox works properly.

    A couple of important observations though:

    • Firefox performance took a serious hit on Skeletor in Space, I get a lot of slowdowns/speedups now that audio works.
    • In IE9, game was silent for a few seconds but then audio played properly. I guess this is caused by preloading a lot of audio, as stated on the Construct 2 manual.

    Now that I finally solved a mystery, can I get a discount on a license pls?

    <img src="smileys/smiley2.gif" border="0" align="middle" /> <img src="smileys/smiley2.gif" border="0" align="middle" /> <img src="smileys/smiley17.gif" border="0" align="middle" /> <img src="smileys/smiley4.gif" border="0" align="middle" /> <img src="smileys/smiley4.gif" border="0" align="middle" />

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)