Audio seems to be totally broken?

  • Since I downloaded Construct 2, I have been unable to get audio to work in any of the games I make. I have tried with WMA, MP3, OGG, m4a, and AAC file types, but either a)Construct 2 doesn't recognize that I've imported a sound or more importantly b) I appear to have done everything correctly and no sound plays upon preview. I have even tried things like on layout startup play sound x.ogg and nothing! It does this with custom sound files as well as all the sound files included in the "starter pack"

    I am running Windows 7 on a Boot Camp'd 2010 Macbook. I have the latest version of Construct 2.

    Does anyone know what might be happening?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Also, really sorry if this is the wrong place to put this. I don't think it's a bug with C2, but perhaps a compatibility issue?

  • What browser? And are you by any chance pre-loading? I have really bad experience with pre-loading, try to stream it instead. Also posting a .capx would help.

  • Does any of the arcade games work correctly?

    http://www.scirra.com/arcade

  • Do other applications play sound? If not, maybe your audio driver isn't installed? The sound volume icon in Windows 7 will show a little green meter going up and down if there should be sound playing, regardless of whether or not you hear it.

  • nihakue did you try to play "x.ogg" or just "x"? I think C2 requies just "x" without extension and plays the fitting format (ogg/mp4).

  • Hi all, thanks for the speedy responses! :)

    so scirra.com/arcade/games/addicting-action-games/93/8-bits-runner works, and I can hear sound, however

    scirra.com/arcade/games/addicting-rotary-games/848/airscape

    works up until I actually start playing the game. Meaning the menu and cinematic have audio but the game itself does not.

    I am using Chrome. I tried to preview in Firefox but my game did not function properly.

    Epox, I tried that, yes. I also tried doing the "Play" action instead of the play by name action.

    Ashley, all other sound works on this computer.

    Vampyrical, I am not preloading anything. Does that mean I am streaming by default?

    Thanks all. P.S. here is an example. See if you can get sound to work.

    Example

    (Sound should play when you press the left arrow once.)

    Thanks all. :) Any help I could get in the next hour would be so helpful. I've actually got to teach a 4th grade class at 9 my time. haha

  • nihakue, the sound worked for me. Here are my specs:

    • Windows 7, 64-bit
    • Chrome 18.0.1025.168
    • C2 R87

    I hope that helps.

  • It works for me too.

    Win 7 64

    Chrome latest version

    C2 R88

    This is a strange issue.

    PS: Yes, you are streaming.

  • I am so confused. Here are my complete specs.

    Intel Core 2 duo CPU 2.26 GHz

    2 Gigs Ram

    Windows 7 (32-bit)

    Construct 2 V84 (32 bit)

    Rendering with OpenGL 3.3.0

    -oh! I am updating my graphics driver now. That may be a thing.

    Edit: Nope. No joy. I checked and I have the latest audio drivers as well. :/ So strange. Everyone I send it to can hear it, but I cannot.

  • A development! I switch over to the Mac OSX side of my computer and load up the game via that dropbox link and the sound works?!

    I am more confused than ever.

  • Updated all my drivers. Still can't get it to work. Any other insights?

    I am going to download a bunch of different browsers

    Edit:

    So sound works when I use the latest version of safari! However html5 games in safari seem to run a lot slower...

    Edit 2: Latest version of Firefox also works. I guess it's a problem with chrome. Interesting. Maybe I will submit a bug report?

  • Uhh... maybe the problem lies in the virtual environment?

  • Bootcamp isn't a virtual environment (i think), It's an actual windows installation. But I agree that bootcamp is what is causing the issue. Because chrome works on the mac side of things.

  • Ah it's Bootcamp. I really think that might be causing issues. maybe you need to report to Bootcamp?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)