APK upload denied at Google Play (CocoonJS plugin)

  • Hi Guys,

    Not sure whether this is construct related or something for ludei / cocoonjs team (or maybe problem i have to fix myself?)

    I have a game which contains IAP (in app purchases) via the cocoonjs plugin that's in Construct R175.

    This works quite good but .... since 1-aug-2014 I'm not able to upload my new build APK's to google anymore.

    It reports that It's not allowed due to version 4242000 of google play-services which are used.

    It also reports that minSdkVersion needs to be 9 or up.

    Is there something i'm doing wrong or needs to be updated on my side?

    cheers

    //Xam

  • the advertising ID of google play services is the problem, but i dont know how to solve this either

    since there is no place on cocoon where we can enter the ID

    any one can help ?

  • Same problem here

  • Same problem here

    Only with banners / advertisement or with IAP?

  • Ok I think Ludei fixed it. What I did to resolve this issue.

    Check the minimal version on CocoonJS website (under projects > Settings > Android) which should be 2.3

    Recompile using version 2.0.2

    Now I'm able to upload my APK's again, Yay!

  • Im late to the party but this is because Admob (Google) now, since August 1st, requires "minSdkVersion = 9" which is Google Play friendly. I had the same errors updating apps over the weekend (native android apps not CS2 apps) and had to use the '9' in the manifest xml.

  • Just to clarify for everyone. Make sure you use a minimum of 2.3.3 in the Android options of the cloud compiler.

    I ran into the same issue over the weekend .

  • If I put another version of android, I will have problems then?

  • If I put another version of android, I will have problems then?

    No, all versions above 2.3 should work ( it seems it is not possible to select a version < 2.3 anymore anyway)

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • No, all versions above 2.3 should work ( it seems it is not possible to select a version < 2.3 anymore anyway)

    Thanks for the clarification, I have only used from version 3.0, for performance reasons, devices with android lower than this are very limited

  • The problem was derived from a requirement from Google. Every android application on the Play Store must have certain libs included, as JLH1964 stated.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)