Windows8 Exported Issues

0 favourites
  • Link to .capx file (required!):

    http:// Is already included in C2 templates

    Steps to reproduce:

    1. In C2 open a new Windows8 Project template

    2. Add some details for Author and Description

    3. Export as windows8

    4. Open in visual studio

    5. Double-Click the package.appxmanifest file in Solution Explorer

    6. Select the Packaging Tab

    7. Click 'Choose Certificate\Configure Certificate' and 'Create test certificate

    8. Run the application

    9. Invoke the Settings Charm

    10 Select 'About' 'Support' or 'Privacy Policy' option

    11. Click the back arrow in the Charms Bar title area

    Observed result:

    The Charms panel closes

    Expected result:

    Should return to the Settings panel

    Browsers affected:

    Chrome: yes/no

    Firefox: yes/no

    Internet Explorer: yes/no

    Operating system & service pack:

    Windows8 Pro

    Construct 2 version:

    r125 beta

  • We ask Windows 8 to re-open the settings when you click that button, but nothing happens. Not sure why it's not working. thehen, any ideas?

  • Hi Ashley,

    Just to let you know that the problem still persists in R126.

  • I just found a general exporter bug in r126. Take a look just in case this bug has something to do with it.

    I is simply "cr.functionname" being replaced with "cr_functionname" in index.html, causing runtime exceptions.

  • arcalaus - that is unrelated to the issue in this thread.

  • Good morning Ashley,

    Any heads up on this - I have a game that's almost ready to release to the Store.....

  • Nope, no idea. We've always had code telling Windows 8 to re-open the charms panel when you click back, and Windows 8 ignores it for some reason. I'm not sure what we could change to try and fix this, since it's a single function call and it's not working.

    Surely it's a minor issue that won't block you releasing?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Hi Ashley,

    I agree it is a minor issue, but it does detract from typical Charms behaviour.

    This has only started happening in recent releases of C2 - R119 and at least R122 worked fine.

    So something has changed since then either with C2 or Windows8...

    Perhaps you could query MS about it....

  • Ashley I only just saw you'd tagged me - didn't notify me for some reason. I've added this to my investigate list. I noticed it works correctly in the Microsoft sample so something's amiss.

  • Ashley


    The problem goes further:

    If you click a hyper link to email or web the charms bar just closes and the link is ignored....

  • Just to let you guys know, the export works perfectly up to R123.

    With R124 the Back button and any Hyper links fail to work as expected.

  • michael good find. I was just about to investigate after realising it used to work in an older build. Also it works fine as-is on touch devices.

    michael can you test on a basic project that doesn't use the mouse object?

  • thehen, will do.....

  • Ashley, here is the info I posted in other thread as requested:


    I agree it is minor - to a degree.

    It is annoying, yes, when the panel closes when clicking the back button.

    But as stated, it is more than that, because it does stop the user accessing options presented to them. If they click any hyper links they don't work - it just closes the Charms and does nothing else, which is not good from a PR perspective - imagine an average end user clicking a link to send an email for support and it does nothing, what would they conclude from that?

    I am thinking that it may not be the plugin that is at fault.

    This morning I did a few install\uninstalls of C2 and found that up until r123 the Win8 Export works perfectly, including any hyper links - however with the release of R124 and all iterations after, the export no longer functions as intended.

    This would seam to indicate that the plugin is not at fault here, something was introduced\changed in R124 that has broken both Scirra and iunkin's win8 objects.

    There are a number of apps in the store built with C2, Mortar Melon, Battleship Islands, Ballo, Blast The Bricks, to name a few, that also illustrate that the plugins do work (the back button and any hyperlinks all function as expected), but these were built with versions prior to at least r119 I believe. This would seam to indicate that it is not Windows8 causing the issue.

    So hopefully all this gives you a starting point to know where to look for a possible solution - start with what was added\changed in R124 that could be causing the issue....

  • thehen,

    OK, I tried simple project, removed the mouse object and exported it, added a couple hyper links to support page, but still exact same issue.

    Oh man don't you hate that, just when you think you might be onto something...

    That is using R126 by the way....

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)