Severe audio lag on cloud debug APK builds for Android, but only over Bluetooth headphones

  • Oh, boy!

    It's a very annoying one, since I want to release this game soon, but literally every device I tested on has a delay of about 1 second. (Huawei P8 Lite, Samsung Galaxy S8, Huawei P20 Pro) As mentioned in the title, this only affects audio coming out of a Bluetooth-paired headset. I tested 2 of those, with the exact same result (Hesh 2 Wireless and some Senheisser ones).

    Audio object properties

    Timescale audio - On

    Salve/load - All

    Latency hint - Interactive

    Project Properties - Advanced

    Runtime - Construct 3

    Use worker - Off

    GPU preference - Default / High performance

    I may be doing something wrong here and not be aware of it, in which case, please move this out of the Bugs section of the forums.

    I tried diferent configurations of the above settings and nothing did the trick. Also, I can't switch the project over to the old runtime because it's heavily dependant on the new C3 features, like color for sprites and such (an essential feature to keep things lightweight!). I only made builds for Android 5 and 6.

    I will release my game anyway, but it would really suck to have a disclaimer in the description pointing out this bug that seems to be trivial, but I can't figure out.

    Thank you!

  • I forgot to mention - I also created a build with the sole purpose of testing this bug, if it is indeed a bug.

    I only have an Audio object and a Touch object. and one single action - Play sound - in a single event - On tap gesture.

    It is reproduced. The delays is still present over bluetooth alone.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • AFAIK, this an android issue. Almost everygame will have this. Cant remember why, but it iss reproduceable for me with many games (maybe all, but i dont play that many also not commonly using BT phones).

  • Bumpy bump

  • AFAIK, this an android issue. Almost everygame will have this. Cant remember why, but it iss reproduceable for me with many games (maybe all, but i dont play that many also not commonly using BT phones).

    Sorry, Cassiano, I missed your post before bumping :P That seems like a BIG problem, though, especially when the game I'm working on is pretty action-oriented.

    Bummer.

  • Construct doesn't control the audio playback - as mentioned that's handled by Android. Since this is not a Construct issue, closing.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)