when saving to temp file

0 favourites
From the Asset Store
Source File, music and art pack for Android Negotiator
  • i had a temp capx open and was working in it and at one point i ctrl-saved

    dialog box ....

    message:failed to move .capx.tmp to .capx!

    i was thinking it crashed, but i after clicking ok i could do a normal save,

    if something like this happens i think it should instantly know you want to save to a new file

  • Can you reproduce this? Are there any steps to make this always happen or is it a one-off? This message should in theory never appear, so I want to fix the real problem, not just make it do another save afterwards...

  • yes, just open a capx from the website, change something in the file en ctrl-s should reproduce it, for me it does

    to be sure:

    i use this link


  • Most systems don't allow you to save to the browser temp folder.

    Just click save as, and chose an alternate path.

  • im only stating there is a nicer solution, instead of the temp dialog

  • vtrix, it saves just fine here, no problems at all. Can you copy+paste the entire error message that you get? It may include details of the problem.

  • hmm just tried it again, same dialog



    im on vista 64

  • Huh, are you sure you have access to the file? It's not in some system directory or something? When you save everything is written to a .capx.tmp file, then at the end it deletes the .capx file and renames the .capx.tmp file to just .capx. This should make it impossible for an incomplete .capx file to ever be saved.

    When you see that error, browse to where the file is saved. There should be yourfile.capx.tmp in that directory. Is there also yourfile.capx still there? It should be deleted by that point, and the rename will fail if Construct 2 cannot delete the original .capx file.

  • i thought it would be a quickfix :) i dont really mind, its probably something on my end, dont loose time over this!

  • Could you check for the files I mentioned? Would be useful to help work out what the issue is.

  • like i said, it was a file from the website, i opend it and did some work on it, it wasn't saved anywhere before, so i wouldnt know where to look, but when pressing ctrl-s i expected to get a save dialog

  • Ah, I see - does it happen on files saved normally to Documents though?

  • Got Error: 'Error saving project' with 'Message: Failed to move .capx.tmp to .capx!' a number of times in this 'How to make a Platform game' tutorial especially when I made a complete platform on page 8 of the tutorial and tried saving the file a few times.

    In all but one case, I corrected the problem by making a small change in the layout such as moving a 'Tile' instance back-and-forth and then I was able to save the project.

    In one case, I had to save the file to another filename and then save it again to the previous filename, but again I was able to save the file with no loss of work.

    For the sake of completeness I am posting this comment in the tutorial at: goo.gl/lKXg0.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • jwjb - which folder are you saving to? Are you sure you have permission to access that folder?

    This error occurs if Construct 2 is unable to delete and then rename a file. So it is very strange if this fails. The most likely cause would probably be that you don't have full permission to access the folder you are saving to.

  • Ashley, I am running Construct 2 as an administrator on my laptop and saving to my own reverse domain folder designation to keep everything organized with the many engines I have used in the past at: C:\Users\John\Desktop\source\projects\com\scirra\tutorials.

    In light of your post, even though I am logged into my laptop as an administrator, I just went to C:\Program Files\Construct 2\Construct2.exe and set Construct2.exe Properties > Compatibility tab > Privilege Level -> Run this program as an administrator.

    Hopefully, this will force my administrative privileges for running Construct 2 if for some reason running as an administrator does not work as default.

    I am running Windows 7 Home Premium (6.1.7601 Service Pack 1 Build 7601 ) and have not noticed this problem like I did running Windows Vista in the past where I had User Account Control (UAC) problems all the time.

    After making this change I see 'Construct 2 (Administrator)' displayed in the top of the Construct 2 program window which I did not see before "forcing" this program to run in Administrative mode.

    Thanks for your reply Ashley and for letting me know if there is anything I should be doing more than what I just set in the UAC and I will let you know if I continue to have this problem after making the above change.

    I am really enjoying using Construct 2 r95 since July 19 and purchasing it on July 25. Running a quick search in my evernote account I see that I originally ran across Construct 2 this past November 22, 2011 and again on December 15, 2011 when I was looking at various other platforms (Corona, Moai, Unity, Unreal, Stencyl, Game Salad, and others) in the early adopter stage of Construct 2 to augment / replace what I was doing in Flash and wish I had started using Construct 2 back then as it seems a lot more intuitive to me which I hope to use for quickly prototyping and then building games.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)