when saving to temp file

  • Ashley, I have been using Construct 2 for a number of hours today and have not had any problems after following the procedure in my previous post so it looks like it is smooth sailing here on out for this issue. Thanks.

  • Ashley, I just wanted to let you know that I had a repeat of the error today 'Error saving project' with 'Message: Failed to move .capx.tmp to .capx!' with all the conditions the same as before.

    So apparently running Construct2.exe as an administrator per the above posts has not fixed this issue in my case.

    As before, I had to save the file to another filename and then save it again to the previous filename, but again I was able to save the file with no loss of work.

    Again, no hurries or worries here, but I did want to post this to the forum for completeness sake.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • jwjb - I'm afraid I'm at a complete loss as to how this could happen. It seems Construct 2 with administrator privileges is unable to delete a file from the Desktop folder (which it should have permission to access anyway).

    I can only suggest that you try to find a way to reliably reproduce the problem and send me the project and steps to reproduce so I can see if I can get it to happen my end.

  • Ashley, as the problem is intermittent at best it will be hard to do this I think, but if I can reliably reproduce the problem I will email you a shared link where you can download the project which is just my file working through the Building a platform game - a beginner's guide tutorial.

    By the way, in the interim is there a log file that Construct 2 logs errors to which might give you an error signature to help with your analysis.

    On a completely different error, but for the same .capx file I just received this error when I tried to run the game which I cannot fix by saving to another filename etc as I did before:

    'HTML5 exporter - Error during export: Cannot open file 'C:\Users\John\AppData\Local\Temp\c2-2BD38M\html5\data.js'

    So then I saved this .capx and tried to open it and and I got another error:

    'Failed to load texture - Error loading texture 'C:\Users\John\AppData\Local\Temp\cap2MF79F\Animations\Flooring\Default\000.png': Failed to read image file data. This may indicate a corrupt PNG file in the project directory. The image will not be able to be displayed in the editor.'

    To this end, I am emailing you a shared link where you can download the .capx file so you can see where I am at now.

  • Ashley, Still not able to reliably reproduce the problem and not sure what was the problem that caused the errors in my posts above and in the files I emailed you the shared link for, but I think I will do the following workaround which I have been using for the last few hours with no recurrence of any errors.

    Whenever I save a file, I will do a 'Save As Single File' which I will append the date (YYYYMMDD) and time (HHMM) to giving me a filename such as: file_YYYYMMDDHHMM which should alleviate 'Error saving project' with 'Message: Failed to move .capx.tmp to .capx!' since it seems to me a new .capx will be created every time it is saved without having to save the same .capx over and over again which seems to be one of the ways the problem crops up especially for files I have saved over and over again many times without exiting Construct 2 which was the scenario for the most recent case.

    Then at the end of the day, I can just delete all but the latest .capx.

    Again, no hurries or worries here, just wanted to post the latest for completeness sake.

    Construct 2 Rocks!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)