Playing c2 projects locally

  • Problem Description

    I have a local python server that serves a local directory to localhost port 9000 and i run my projects locally with chrome.

    This problem start after ver 200, projects are not loading when access them the first time, show missing images files in browser console and a red bar, though they exist, when pressing F5 to refresh they load fine.

    Attach a Capx

    This happens with all projects, on C2 ver 205 and i also tested on ver 204.2, reverting back to ver 200 everything works fine.

    Affected Browsers

    • Chrome: (YES)

    Operating System and Service Pack

    Windows 7 sp 1

    Construct 2 Version ID

    tested on version 204.2 and 205

  • Are you sure this is not a problem with your own server?

    The C2 preview mode is not designed to work with any other servers, and various files are modified during the preview process. I'm not clear exactly what you are trying to do, but it sounds like it's not supported.

  • It's just a local http server, it worked fine for the last 2 years, and it is fine on version 200 with the server.

    I am trying other betas now between 200-204, to see when exactly it went wrong.

    So far on 202 it works fine too.

    203 is also working fine.

    @Ashley

    Ok, The problem starts with version 204.

    It looks like the loading screen (built in, not loader layout) is stuck for a few seconds, then i get a couple of

    Error loading image 'http://localhost:8016/main204/images/house-sheet0.png': Event {clipboardData: undefined, path: NodeList[1], cancelBubble: false, returnValue: true, srcElement: img…} c2runtime.js:104

    GET http://localhost:8016/main204/images/town-sheet0.png net::ERR_CONNECTION_REFUSED :8016/main204/images/town-sheet0.png:1

    Error loading image 'http://localhost:8016/main204/images/town-sheet0.png': Event {clipboardData: undefined, path: NodeList[1], cancelBubble: false, returnValue: true, srcElement: img…} c2runtime.js:104

    GET http://localhost:8016/main204/images/mytown-sheet0.png net::ERR_CONNECTION_REFUSED :8016/main204/images/mytown-sheet0.png:1

    Error loading image 'http://localhost:8016/main204/images/mytown-sheet0.png': Event {clipboardData: undefined, path: NodeList[1], cancelBubble: false, returnValue: true, srcElement: img…}

    then it continues loading but the bar turns red and never finishes.

  • I don't know how your own server for previewing works - when previewing, some content is served directly from memory and does not exist on disk, so I don't know how you could set up your own server to run a preview. Are you exporting every time? Either way the error says "connection refused", so it seems to be an issue with your own server refusing connections.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • It's not a preview, i am exporting to html and running locally, the server side hasn't change since i started the project and it works good up until version 204, can't you think of something you've changed that might have caused this?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)