Play Bug

0 favourites
  • 5 posts
From the Asset Store
A set of board games to make your day joyful. Play, Enjoy, Relax
  • Keep's occurring when I click play


    Here's the error


    Construct 2 Check failure


    Check failure! This is probably a bug:

    GetSingleGlobalInstance(): is not exactly one instance

    Condition: insts.size() == 1

    File: Projects\ObjectClass.cpp

    Line: 573

    Function: class era::IObjectInstance *__cdecl ObjectTypeERACallback::GetSingleGlobalInstance(void) const

    Build: release 93 (64-bit) checked

    Component: Construct 2 IDE

    (Last Win32 error: 0)

    You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.


    Abort   Retry   Ignore   


  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Isn't this the same as this other bug you reported?

    I'm afraid my comment is the same: we cannot do anything about this. We need more information to be able to solve the problem.

    Also why are you still on r93? r95 is out now and is stable.

  • Not really, it doesn't crash instantly. Now the error message appears.

  • ZZZZZZZZZZ i decided to pick up from before again. I got up to where i wanted to get up to and played the game and it worked fine. Saved it and closed and re-opened and tried to play it to test it. But it crashed for some reason.

    It stop's working once I save and reopen it, If that helps.

    the new capx:

  • - that .capx doesn't work after opening it, so I guess saving and closing does not affect it.

    The first time the Mouse object became corrupt.

    The second time the Keyboard object became corrupt.

    This time the Playtomic object became corrupt.

    I'm afraid none of the projects you've sent me help me solve this problem. They are all already broken, whereas to fix this I need a project that is not yet broken, and steps to break it. Are you sure you can't think of anything you've done that might have caused this? Whatever you've done, you've done it three times, and each time has broken the project. Perhaps each time was something to do with using the object that became corrupt, or perhaps not. Either way I would love to fix this to make sure it never happens again. Any ideas?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)