Ejecta Turbo Issue

0 favourites
  • Problem Description

    Game runs unusually fast after minimize the game (pressed iPhone's home button) and come back to the game result in turbo speed. Monitor with xcode's debug, shows CPU usage go up, and FPS drops every time re-enter the game.

    Attach a Capx

    ejecta_turbo.capx uploaded!

    Description of Capx

    1 Object with sine behavior, and text showing timescale.

    Steps to Reproduce Bug

    • Step 1. Create any game, in this case an object with sine and text object.
    • Step 2. Export with official Ejecta exporter, NO minify.
    • Step 3. Download and extract latest ejecta from https://github.com/phoboslab/ejecta
    • Step 4. Rename exported folder to App, copy to ejecta folder.
    • Step 5. Open xcode file, change bundle ID & team, run test on iPhone 5(also tested on iPad 3 same problem).
    • Step 6. Press home button.
    • Step 7. Press ejecta icon(back to game)
    • Step 8. See the turbo or jumpy performance. (this is a very simple project so it might not be noticeable, repeat step 6 & 7 a few times to see the issue, or monitor CPU & FPS from xcode's debug)

    Observed Result

    Uses more CPU and game runs faster than it should after minimize the game and come back. On iPad3 it went from 60fps(first launch normal speed), to 25fps(after minimize and reenter game 5~7 times)

    Expected Result

    Game performance unchanged after minimize and come back.

    Affected Browsers

    • Chrome: (-)
    • FireFox: (-)
    • Internet Explorer: (-)

    Operating System and Service Pack

    Win7 64bit latest / OSX latest + latest xcode

    Construct 2 Version ID


  • Ejecta just merged a patch I submitted which I think will fix this. Can you try re-downloading Ejecta and see if it's fixed?

  • Ashley yes!!!!!! both the turbo and accelerometer issue fixed and its running much faster(performance wise) than cocoonjs, you should suggest those who complaint mobile performance to try ejecta, its a big improvement over cocoonjs, thank you so much!

    however i notice some more bugs, audio pause is not working, and audio play rate also not working on ejecta. do i need to file another bug report? its quite simple

    and on a side note, not relate to ejecta but its the exact same turbo issue now happening with the just released cocoonjs v2, i think you know what exactly the problem is, maybe you can pin out the problem to ludei? :/

  • hollowthreat - yeah, submit another bug report for pausing, but I think playbackrate isn't implemented and will be difficult to add since it involves a fairly sophisticated bit of signal processing. If the old CocoonJS didn't have the bug it must be Ludei's fault, so report it to them (or just use Ejecta).

  • Ashley ok i'll submit another one tomorrow. as of cocoonjs bug, yes they don't have that issue on old version, i'll try report to them, not sure how to reach them properly, asked 2 question months ago, no reply at all :/

    i'm seriously considering using ejecta with my new game, just need to sort out iAd, and a social sharing problem. are you able to look into this, https://www.scirra.com/tutorials/914/fa ... r-cocoonjs

    its not working on ejecta, it wouldn't open the browser, this will be a very useful solution for social sharing feature for ios games.

  • hollowthreat - the Browser object's 'Open URL' action should work in Ejecta. Does it work at all, or just not for a particular link you've tried?

  • Ashley Open URL does work in ejecta, only particular link(contains space in URL, for sharing dialog), any link with space it won't respond and open, the work around from that tutorial is to use encodeURL which works on cocoonjs, but not ejecta. any possible solution? sharing score to facebook & twitter is essential for infinite game, thanks for look into this!

  • WOrks great now with Ejecta. Only one sound sfx does not play as should. volume is set at 0db so dont know whats the problem. Rest works

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Might be an option to use a ejectas extension for this.

    You can bind js code to native functions

  • hollowthreat - how about using the URLEncode system expression in Construct 2 itself?

  • Ashley ok I'll test that now, not too sure how to use that system expression, does this look right?

    "https://twitter.com/intent/tweet?text="&URLEncode(I just scored highScore in blah blah blah!)

  • I can't get URLEncode to work in C2, It'll show syntax error in C2 whenever theres space. so my line above can't be right, read the manual, still don't understand how to use URLEncode, any example?

  • Ashley something buggy with ejecta plugin i cant reproduce, my game now gets stuck in launch screen and xcode shows this error

    2014-04-05 16:29:29.559 Ejecta[1521:60b] SyntaxError: Unexpected token ','. Expected a property name after '.'. at line 62593 in index.js

    even change back to normal URL still the same, i simply don't know what went wrong, i have this same error when i first add ejecta object, while my file still has cocoonjs, i', not sure if it could be any sort of conflict? i removed cocoonjs object from my file, it export fine before(last 2 days), and today i'm just trying to get ejecta to show iad and gamecenter, both doesn't work, didn't change anything else, and now everytime i export from this file i get such error.

    i roll it back to earlier working cocoonjs file, and tried remove all cocoonjs events first before delete cocoonjs object, then add ejecta, i still get that error from xcode, i manually remove the '.' from index.js, now iad and gamecenter works, but touch is not functioning properly..... weird. i don't know if this give you any clue, if you want to investigate my file, i'm happy to show you over email. (as its completed project)

  • Ashley ok i've found out whats causing the problem, ejecta gamecenter's 'is authenticated' is bugged, i believe that cause all sorts of problems, include touch, iad, gamecenter, sound pause. I'll post a bug report soon.

    Sound pause on ejecta is working fine. However I still don't know how to use URLEncode() in Open URL, so I can't test that yet.

  • The 'Is authenticated' issue was already reported and is already fixed.

    Are you new to C2? Strings in expressions need double-quotes around them, which you'll need to use in the URLEncode expression as well.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)