Construct 2 wont run

0 favourites
From the Asset Store
Full game Construct 2 and Construct 3 to post on Google Play
  • Problem Description

    C2 wont run with two different errors, one after a clean install and one when trying to run (in both admin and none admin).

    After installing I get -

    Unable to execute file

    CreateProcess failed; code740

    When trying to run I get -

    The procedure entry point (then a garbled mess of icons and stuff), could not be located in the DLL

    Operating System and Service Pack

    Windows 10

    Construct 2 Version ID


  • Does this reproduce with r212.2?

  • Yep

  • [quote:2bvfnv65]CreateProcess failed; code740

    I believe this means that you don’t have the correct “rights” to perform the operation.

    First Try disable UAC <---hate this bloody thing lol.

    See if that works. And that will highlight if that is the issue or it could be registry files, etc etc

    I know you uninstalled it and reinstalled it. Did you do a reboot between the two? Uninstall. Restart. Re install. Restart. Note the restart.

  • It was all working fine until today.

    UAC changes make no difference.

    I did a restart between unsintalling/install with the same errors (though the garbled mess of stuff changes).

  • Error 740 is ERROR_ELEVATION_REQUIRED ("The requested operation requires elevation.") - perhaps try right-clicking and running as administrator? It's odd though, C2 should run just fine without any elevated permissions...

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Yeah, I've been running it as admin (set in properties) fine up until today. I don't think it's directly a C2 problem but so far is the only app that wont start.

    I get the elevation error after installing and the dll error when trying to run the exe

  • I had similar issues awhile back. Running I recommend these guys if you don't know how to custom write your own script and their little free program basically restores permissions as they should be, fixes registry etc etc etc long list. Be sure to follow each step. i.e backing up registry files, running a malware scan, system restore etc etc.

    It worked for me... but my issue was bigger than that eventually. I found I was getting blue screens often, and I eventually tracked down 30bytes of corrupt memory sector, that believe it or not, when a program accessed it, it would then corrupt what it passed onto disk. So my only solution was to buy new memory, and start with a new disk (got a solid state and never looked back) Of course, my issues vs yours won't be the same.

    BUT, for some unknown reason your permissions are broken (this can be a result of so many things - even malware)

    Try windows fix software. It doesn't do anything, except restore everything to what it should be - it even checks your windows installation to ensure no files have gone missing etc etc. Very nice program.

    I used it for 7, and windows 8. I haven't used it for windows 10, but I am sure it will be just as good, they might even offer some options to deactivate all the tracking stuff of windows 10 - (Windows 10, worst release yet as far as security)

    [quote:ug0thhad] - Windows Repair is an all-in-one repair tool to help fix a large majority of known Windows problems including:

    Unhide Non System Files

    Repair problems with .lnk (Shortcuts)

    File Association


    Windows Firewall

    Internet Explorer

    Windows Installer (MSI)

    Hosts File

    Policies Set By Infections


    Winsock & DNS Cache

    Proxy Settings

    Windows Updates

    CD/DVD Missing/Not Working

    Reset Registry and File Permissions

    Register System Files

    Remove Temp Files

    and more...

    A quick look, I didn't see windows 10 support


    [quote:ug0thhad]All default permissions for 7, 8 and 10 have all been updated after the windows updates where done for the patch Tuesday of this month (Aug. 2015)

    Okay, seems they added support

  • Tried the tweaking thing, and a reg clean but still getting the same errors

  • Tried the tweaking thing, and a reg clean but still getting the same errors

    Seriously? Oh, wow. How can that be?

    New beta works?

    Umm, actually, have you installed a version prior to r212.2? And it works or doesn't?

    If it works, then I am stumped.

    If it doesn't, then you will need to uninstall, and remove all trace of the software manually and try install again.

    This is the worst kind of issue... and the problem is, that it might have started with construct2, but can start spreading to other software [No attacks you know of, no recent downloads, installs, firewall warnings, anti virus warnings etc] (I'm pulling at straws)

    Sorry I'm not much help.... but this is weird... tweaking should have sorted all those issues

  • All help is great!

    I've just tried uninstalling 212-2 and installing 192, that works fine.

    I'm going to work my way through the other versions and see where it dies.

  • I've just tried uninstalling 212-2 and installing 192, that works fine.

    Then it isn't your pc at all. Hence, I am stumped. It is something specific to construct and that version and user permissions or as ashley says "elevated permissions".

    I haven't a clue. I am running windows 10 and not having same issue. Albeit, I haven't used C2 much last couple weeks.

    This is strange indeed.

    There is a lot of windows 10 features added in recent releases, but I can't comment on that.

  • I thought I'd try 213 (beta) and that works, though it seems that 212 and 212-2 are the problem versions.

    It is very odd!

  • I thought I'd try 213 (beta) and that works, though it seems that 212 and 212-2 are the problem versions.

    It is very odd!

    beta 213 fixed the windows 10 exporter - shrugs?

  • Hello friends! I have a problem , I try to preview, and the arrow keys and touch not work, try making a game -type tennis and the only way that works is the default controls , I've progrmado well reviewed step by step and nothing, this has susecido me after downloading R213 , failure has given them to you too? Thank you.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)