Construct 2 refuses to close

0 favourites
From the Asset Store
Casino? money? who knows? but the target is the same!
  • I see that whenever I work on Construct 2 (Free Edition) for a while, and I hit close on top right or exit the program, the program will not close down. Sometimes it happen. Sometimes it does not.

    Observed result:

    I noticed this. Because this is Free version, the program should display the message and tell me to support and purchase Construct 2. But for my case, after I try around Construct 2 for a while, the program will NOT display this "purchase" message and program will not close down. I can still go to preference, play around, etc. but I cannot close the program down.

    When I summon the task manager, Windows will then prompt me to either wait or terminate C2.

    Moreover, the Recent Project list will revert back to the 6 original capx, should C2 got terminated abnormally in this case. However, the last directory of "Open..." dialogue is not reverted and is still at its last directory.

    Expected result:

    The program should close down.

    Operating system & service pack:

    Windows 7 Ultimate no service pack

    Construct 2 version:

    R126 but it also occurred on R119, before I updated to R126.

    I will keep in touch on this, as I keep on playing around with C2.

  • seems like this particular problem keeps popping up all the time. Just wish this could get fixed.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I've had this issue as well. It seems to happen on random occasion.

  • I get this all the time. Seems to occur the most when i've been working for a while with a bunch of other programs like photoshop open as well. It usually won't close until I bring up the task manager at which time it suddenly pops up a windows "construct 2 has crashed, searching for solution" box. I cancel it and construct 2 is now closed. It wouldn't be such a pain except the next time you open construct you have to manually find and load the last file you worked on, since it's not in history due to the crash.

    Win 7

    Construct 2 Personal R126 64-Bit

    This issue happened on previous c2 versions, as well as the recent update.

  • It happens without fail whenever I try to close it if my computer has been asleep while C2 is running.

  • Usually happens to me if I have C2 open for a long time, like >3 hours or something.

  • I was working on C2 for awhile, and when closing it, it got stuck as well (after it unloaded the project first), but it's very random (most of the time it's fine).

  • And it is really important to force-close C2 if it hangs. Do not open a project up after it hangs open, otherwise the project will throw errors and crash.

  • I think it may be memory related.

    I have had this problem since I started using C2 (R114 - Personal Edition), and it was getting to be a real pain.

    However I have recently upgraded my graphics card to one with 2 Gig of ram (previously one had 1 gig)and the crashes are far less common since the up grade.....

  • Been using C2 every day for the last few weeks for a project. All the time it will not close, so now I have the habit of just opening the task manager and forcing it to close (it'll still say its not responding and to cancel).

  • I think before this problem gets sorted out it's best to close C2 by double clicking the left top corner file button. It should close everything without any crashes.

  • Ashley doesn't know how to fix this yet. I've been using a .bat file to close Construct 2, since it always takes forever to close. Someone suggested this ages ago somewhere, but I'll summarise/repost the advice:

    • Create a text file called something like "close construct.bat"
    • Put the following text in it: taskkill /im construct2.exe /f
    • Save it and your done, place this file somewhere so you can easily close construct quickly (I have it on quick launch bar).
  • It's not the graphics card memory, I have 4 gigs on my graphics card, 16 gigs in the machine.

  • Same here, I Have dual 5970's (Quad GPU Crossfire X) with 4GB DDR5 and 12GB DDR3 for the system and I still get the issue, though it seems to be more prevalent when I have a graphics app opened like inkscape or illustrator.

  • It's not a bug, it's a feature

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)