Construct 2 refuses to close

  • This happens to me too, and it does seem to happen more often if the program has been open for most of the day.

  • same here, and i can't determine a cause. it happens in what it seems, a random basis.

    Happened with free version since i use C2, happens in personal as well.

    specs:

    C2 Personal 64bit r128.2 beta

    Intel Core 2 Duo 2.20 GHz - 4GB Ram - Geforce GT320M 1GB VRAM

    Windows 7 Home Premium x64

  • btw this also happens on r132

  • Still happens in r133

  • Still happening here as well.

  • Was just about to start a new thread when I saw this one.

    Been happening to me for the past three beta updates. Including the latest r135. I can't find any patterns except for having the program open for an extended period of time. Like two or three hours +

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Just confirming that it still happens to me also.

  • Weird. This hasn't happened to me yet, and I've been going crazy playing around with C2 the last few days. :p

    Perhaps it has something to do with particular install versions of C2? Like maybe it isn't reading 64-bit system and installing the 32-bit C2 on 64-bit systems?

    I honestly have no idea if anything is different with my version (free, latest beta update)

    The only bug I've ever had so far is the dang alt-tab crash. :p

  • I get this too, I was just checking for a solution.

    The longer C2 has been open, the more likely it is to to this - that's the only pattern I can find.

    Running W7 x64 with r132 64 bit version, though I don't think that matters.

  • Same issue. r132

  • I'll chime in. Happens to me as well, on at least 4 of my computers, Windows 7 and 8.

  • New glitch that actually has a benefit in this situation, when it happens and Construct2 won't close, on the empty project screen press ALT-f4 and it will crash, closing the stuck program.

    edit: No, it's not the same Alt f4 that was fixed, this only works after Construct is in the "stuck" state. r138

  • I've had the same problem since I started working with C2, the program freezes upon trying to close it, then I have to CTRL-ALT-DELETE it and then it doesn't respond. Almost never closes properly, happened regularily both on R132 Free and Personnal license, and R139 in Personnal License. I'm on Windows 7.

    I also get a bunch of crashes in general, seemingly at random, so I have to save often. Maybe it's all related to the size of the file? My project has 583 Events, it's Approx. download is 34.6 MB and it's memory use is 136.7 MB.

    Anyhow, I really hope this is improved sometime, the program not closing is kind of annoying, but the recurrent crashes are sometimes very upsetting; sometimes it seemed like the Ctrl+S command actually prompted the crash (not very convenient lol).

    Anyways, good luck with all this hard work, thanks so much for the great program!

  • Same problem here. Just tried closing it now. And it closed all open files, but didn't close the program.

    Recipe up to this point:

    I did leave my pc on last night and I know that ccleaner ran last night whilst I was asleep. I tried closing it now cause it wouldn't launch applications saying something about java not being something. (Still rubbing sleep out my eyes)

    Something about the temp file. I presume ccleaner wiped out the temp file directory and C2 doesn't like that.

    I'm drawing at straws here. Lots happens on my machine, very hard to pin point a single instance that could be the cause. But it was fine last night before bed, and now when i just sat down it gives problems. The only diff is the ccleaner clean / wipe last night.

    I didn't schedule registry so that isn't it. I guess temp file missing something that C2 needs to function/close or junk system file. That is what I have... first time it has happened though.

    I am finding issues with the steam version unrelated to this though. But I am running the steam version of C2 if that helps narrow down. But I guess most here aren't.

    Edit: Yip I see why I couldn't launch my project files (run layout) I see all the scripts stored in temp. I won't be wiping those again whilst using program ;)

    Edit: Nope ccleaner wasn't cause of C2 not closing. Just tried again and couldn't recreate it. It Closed down no problem.

  • It still happens on r146, it happens at random for me.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)