Construct 2 r158.2 crash at startup

  • Link to .capx file (required! If link is blocked remove the http and www parts):

    Steps to reproduce:

    1.

    2.

    3.

    Observed result:

    r158 and 158.2 crash at startup with ole32.dll error

    Previous version r156 works great.

    I had a problem with r154 and 155 - kernel32.dll problem at startup too.

    Could You repair stable version r.158.2 ?

    Expected result:

    Browsers affected:

    Chrome: yes/no

    Firefox: yes/no

    Internet Explorer: yes/no

    Operating system & service pack:

    Vista 64 bit SP 2

    Construct 2 version:r158 and 158.2

  • I'm having the same issue. <img src="smileys/smiley19.gif" border="0" align="middle" />

  • I'm on windows 7 64 bit

    Installed construct in administrative mode.

    Launch construct in admin mode and all that comes up is an error box.

    Error window title: Construct2.exe - Entry point not found

    Description: The procedure entry point could not be located in the dynamic link library ole32.dll

  • Win7 64 bits here.

    I am having the same issue. I've tried downloading both directly and from torrent. Both sources yield identical result.

    "The procedure entry point could not be located in the dynamic link library ole32.dll"

    Back in r152, I used to have similar problem but it's gdiplus.dll instead. I solved the problem by keep on re-downloading and re-installing and then I see that the installation exe that works has different file size.

    Not sure whether this is related, but Ashley, could you provide some sort of checksum for this?

  • Lots of systems ranging from the download connection, browser, file system and installer should already be keeping checksums/hashes to ensure the integrity of data. Just in case though, can anyone confirm if downloading from a different internet connection and reinstalling fixes it?

  • I downloaded the file a second time last night, and the files were both different sizes. But the second try did nothing. I just downloaded the release with torrent, and still... Nothing. I will try using the data connection on my phone when I get home :/

  • Just downloaded it using my cell phone data connection. Same issue.

  • Same dll entry point bug here (Win7 x64). I need to continue with a project, so please give a link for the previous stable release. Thanks.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Thanks!!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)