Can't Export Projects with Steam Version

0 favourites
From the Asset Store
Vintage steam pixels for your UI! 125 unique assets in a single pack!
  • I recently purchased Construct 2 through Steam and I'm having issues exporting projects. The 'contact us' section on the website directed me here. I have filled out the bug form below, but I feel this overview might be more helpful to initially describe the problem:

        * I have the paid personal license through Steam

        * I use 32-bit Vista Home Premium

        * I have the latest version of my graphics card drivers

        * I get a DEP Error and a Crash whenever I try to export any Project

    So far so boring, BUT, there is a twist at the end of this story... Having tried and failed to get the export working with my paid Steam version, as a last resort I downloaded the free standalone version of Construct 2 and installed it. The export works perfectly with no errors, every time.

    This for me rules out graphics drivers as a potential issue, and points towards either Steam, or the Steam version of C2 being the issue. As I've used Steam for years with no other issues I thought it best to raise this as a Construct 2 bug

    As a workaround, I can use the Steam version to create games, save the projects, then switch to the standalone free version to export them, but obviously this is not ideal. As a footnote I'd like to say that having used other IDEs, Construct 2 is just ridiculously good, so if I can get this sorted then that would be great. Thanks



    Link to .capx file:

    This is an exporting issue that affects any and all .capx files I've tried it with, so I'm not sure this is relevant. For the purposes of testing I used the included 8 direction movement example.

    Steps to reproduce:

    1. Open any .capx file in C2 through Steam version (paid personal license)

    2. Export Project to HTML5 webstite

    Observed result:

    1) The following errors are generated:

        "pngout.exe has stopped working" (this is generated multiple times)

        "Data Execution Prevention has Closed pngout.exe

        "Java(TM) Platform SE binary has stopped working"

         Construct 2 Crashes

    Expected result:

    Completion of export process with no errors

    Operating system & service pack:

    Vista 32-bit Home Premium (99% sure it's on SP2, will confirm when I get home)

    ATI Graphics 5000HD series (latest drivers)

    Construct 2 version:

    r119 (Steam)

    NOTE: Problem is repeatable at every attempt to export using paid Steam Version, but problem does not occur at all on the standalone free version of Construct 2

  • I just reinstalled everything through Steam just in case, but the problem persists. I also tried the free version through Steam, no luck. Standalone continues to work.

    Is there any way to perhaps transfer my Steam license to a standalone one?

  • Yes the workaround I mentioned actually is no good because of the limitations. So I can't export my projects at all

  • This is very odd, I've never heard of any similar issue from anyone else using Steam or otherwise. It looks like the crash is in pngout.exe which isn't actually Construct 2, it's an image compression utility we use at export time. A possible workaround is to disable PNG recompression on export (set it to 'None'), does that work?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Hi Ashley, thanks for the reply. I have done 3 things to futher test this, the first is to run a full Malware scan, results check out, so all clear there. The second thing I did was to add pngout.exe to the DEP "Allow List". This unfotunately had no effect, as I still got the same DEP error from pngout.exe despite it being in the allow list.

    The third thing I tried was your suggestion of setting png copmpression to none. This didn't give me the DEP error from pngout.exe, but I still got the "Java Platform SE Binary has stopped working". I also then get a new error which reads "the application failed to initialize properly".

    After further testing with different browsers I also noticed that if I try to preview any project in Firefox, I get all the same errors and crashes every time. IE and Chrome are fine. I disabled all add-ons in Firefox, same result.

    As before, both exporting to HTML5 and previewing in Firefox continue to work perfectly in the standalone free version??

    Are there any error logs or anything that would be helpful? I can post screenshots of the errors if you need me to.

  • Construct 2 doesn't write logs. Are you sure your computer is configured correctly and you don't have some exotic settings/software that's breaking it? The Java issue sounds totally unrelated, as does the preview issue, so it sounds like lots of random stuff is breaking that AFAIK is working fine for the vast majority of users.

  • I don't think I have anything particularly exotic, I only recently did a clean install of Vista.

    The thing that concerns me here is that the standalone version is fine, nothing is clashing with that or causing issues with my current setup. If that didn't work either then I would agree 100% that is was definitely my issue. There must be some difference between that version and the Steam version that is causing me the problems.

  • The Steam version is almost identical to the desktop version, but with small tweaks (such as using Steam for authentication instead of a standalone license). So it's odd that having Steam running would cause all these issues. It might be an issue in Steam itself... or possibly failing hardware if your computer's very old.

  • OK, I do understand that it doesn't seem to be a common problem, it's so frustrating when you have these crashes and nobody else does. I know you guys are a small company and there's probably little more you can do from your end. I'll do a full reinstall of my OS, of all my drivers, of Steam and so on in a systematic fashion, to see if I can fix the problems. I'm willing to make the effort as the software really is a joy to use up the point of exporting. Thanks for responding anyway

  • I've come to some similar messages yesterday.

    Construct 2 Personal r119 via Steam in use here.

    I also run a Vista 32-bit machine with SP1 and the graphics drivers with version number 310.70 from 01.01.2013. There is a newer SP and also a newer graphics driver with version 314.07 from 18.02.2013 available. Will update my system later and report results.


    Intel Core2 Duo T6400

    3 GB RAM / 32 bit Vista Home Premium

    nVidia GeForce G105M Cuda 512 MB

    Just checked my Direct X... Version 10, will update this one also.

    When exporting to HTML5 i get the message that pngout.exe has stopped working (popup appears two times)

    After clicking them away Java(TM) Platform SE binary has stopped working appears, also this one can only be clicked away by the button "close program"

    Then a message titled HTML5 exporter says: Error during export: Cannot open file 'C:\Users\Aspire4937G\Desktop\New project\c2runtime_min.js'

    Only can click on OK.

    Until this point the progress bar window for Exporting project is running in the background.

    But then it says that the project has been exportet successfully and asks me if i want to go back to project or open the export folder.

    C2 doesn't crash on my machine.

    I just saw, that there was a c2runtime_tmp.js in it, think it shouldn't be.

    Differs a bit to your version.


    Tried it again with no PNG-compression:

    First error is a java.exe - error in application

    aplication couldn't be initialized properly (0xc0000005).

    Now the same as before.

    Then a message titled HTML5 exporter says: Error during export: Cannot open file 'C:\Users\Aspire4937G\Desktop\New project\c2runtime_min.js'

    Only can click on OK.

    Until this point the progress bar window for Exporting project is running in the background.

    successfully exported... no crash


    Third attempt:

    Exporting and turning PNG compression to Standard (recommended setting) as in first try.

    A dos-box pops up writing fast some lines, disappears and then Java(TM) Platform SE binary has stopped working appears.

    Then a message titled HTML5 exporter says: Error during export: Cannot open file 'C:\Users\Aspire4937G\Desktop\New project\c2runtime_min.js'

    successfully exported ... no crash


    Fourth attempt (no changes in settings):

    Black DOS-BOX with path to C:\Program Files\steam\steamapps\common\Construct2\Construct2-Win32\exporters\html5\tools\pngout\pn showing in title of box appears and the two messages saying pngout.exe has stopped working are there again.

    Closing the first of them makes another dos-box popping u and writing some lines and then disappears.

    Closing the second one just closes the initially popped up dos-box but with no process.

    Then Java(TM) Platform SE binary has stopped working appears.

    Then a message titled HTML5 exporter says: Error during export: Cannot open file 'C:\Users\Aspire4937G\Desktop\New project\c2runtime_min.js'

    successfully exported ... no crash


    somehow i could achieve a working export yesterday, but i don't know how

    Weird... will update the system and have another look at it then

  • Well other than the that fact your CS2 seems to get through the export with no crashes, I'd say that problem is almost identical to mine. I get lots of png errors as well (with compression on) and amongst those boxes I do get the same "cannot open file" error. I also get the "application couldn't be initialized properly (0xc0000005)" error if I turn off the png compression.

    Have you tried uploading and testing the exported files, are they all OK?

    I'm currently uninstalling my other Steam applications to see if that helps. Plus I'm running through clean-up processes with Glary Utilities, Driver Sweeper, Malwarebytes etc. I'll see how I get on

  • Hey SecondDimension - I don't think your other steam apps can be the problem... I only have C2 running on steam on this machine right now.

    And no... it doesn't work, only shows me a black screen. This must be due to the fact that the file c2runtime.js doesn't exist, but there ist this c2runtime_tmp.js, just looks like something went wrong on compiling/exporting.

    As mentioned before yesterday I was somehow lucky and could do a clean export. the c2runtime.js only has a filesize of 87 KB, but the c2runtime_tmp.js exported today with absolutely no change to the project comes out at 305 KB.

    I've uploaded both so maybe some dev can read inside these files... hopefully.

    >> c2runtime.js VS. c2runtime_tmp.js<<

    The big difference really is the fact that C2 doesn't crash at all on my machine.

    I'll do the updates now and write right after I've don them here again.

  • I wonder if you tried the standalone free version if that would be OK for you as well. Plus, do you have any issues with previewing in Firefox? I bet this is something so obscure

  • Standalone free version of r119 stable does its job just perfect. also here. Preview in Firefox also works without any problems in steam c2 personal...

    uninstalled it and created another steam-folder in the root of anohter hdd, same errors, so it can't be because of too long/deep file paths, just thoug i give it a try...

    time to update the rest... java runs on the latest release, and so does the graphics card... some more updates to do, be right back

  • Updated to SP2 now.

    The desktop icon of C2 has now changed to a web document (internet explorer logo on a white blank paper)

    Launched it and exported the same project again with no changes to the settings (PNG standard/recommended)

    First try:

    Export progress bar appears with two dos-boxes. One performing the PNG-processing the second one does nothing. The close automatically

    Then the java error again resulting in a c2runtime_tmp.js being populated into the export folder.

    <font color=BLUE>Second try:

    Just done seconds after the first export with absolutely no changes to anything.

    BAAAAM! Done! Export progress bar two dos-windows and then the pop up asking me if i want to go to the exported project or stay in construct.

    Now there is a nice c2runtime.js in the folder and the index.html works just fine.</font>

    I think I got this result yesterday when I've installed the latest java-update from 7.15 to 7.17, but I'm not 100 % sure about it.

    Now give it a third try:

    Looking good initially but then pngout.exe has stopped working appears again, this time only once. But no java-errors for now. Ok, the project works the images were there before, and I also think by now, that even if this pngout.exe pops up the images though are exported correct.

    Fourth (fear to press the export button already):

    No PNG error but the Java Runtime has stopped working and gifts me a c2runtime_tmp.js


    two pngout.exe errors... java.exe initialisation errors (0xc0000005), no access to file, java binary stopped working, the whole palette...


    java.exe initialisation, java binary stopped working, error on export, created a tmp.js


    java binary twice, c2runtime_min.js cant be opened error



    Reinstalled Java 7 Update 17

    Launched Construct 2 again and started exporting

    Waves of errors as above, did three attempts

    I'll do some research and keep you updated...

    It worked once!!!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)