Black/blank screen on iOS Safari and IE

0 favourites
From the Asset Store
An educational game for Fill in the Blanks. An easy to use template for developers to build larger games
  • Problem Description

    I don't know if this is just a local problem because I have only one iOS Device here, but after updating to r196 and uploading my app again it just shows a black/blank screen. I deleted all browser data on my iPhone but its still showing a black screen. It works fine on PC (Chrome+Firefox) but IE shows only the loading page and is stuck there.

    I did only change one line of code on a layout which is not loaded at startup (fixed a setX). So the only differenc is the export from r196 on the affected layout. Is there something broken?

    Steps to Reproduce Bug

    Observed Result

    The screen stays black or is stuck at loading screen.

    Expected Result

    should load next layout to show intro (first run) or newspage.

    Affected Browsers

    • Chrome: NO
    • FireFox: NO
    • Internet Explorer: YES
    • Safari (iOS): YES

    Operating System and Service Pack

    latest Windows 8.1 and iPhone with iOS 8

    Construct 2 Version ID


  • I'm not sure if this is related but i have noticed also that i'm seeing a similar result with iOS / XDK / Cordova.. now all apps load with a black screen and the status bar still visible.. two different games both that compiled fine with 195.. i'm reverting to 195 now to see if that helps.

  • yes to confirm this, i reverted back to 195 and games run successfully through XDK.

    whatever he is experiencing, I believe it's related since Cordova is also using iOS Safari for the game to run.

    Please please find a hotfix for this. I'm working on a time sensitive project. I've never been burnt before by a beta, I will be much more careful in the future moving beyond a stable build.

    It must be something minor to freeze up a game at launch preventing the rest of a game to work.



  • Cordova is also using iOS Safari for the game to run.

    Actually, it is using UIWebView or WKWebView (with plugin), so it's a problem with c2-cordova or c2-ios webviews.

  • Sisyphus gotcha right but it seems interesting that Bl4ckSh33p is having the same black screen problem and he's not using Cordova, it seems he's having trouble with iOS Safari so they would seem to have something in common, which makes me think it's not cordova.

  • you know, i wonder.. one of the update changes they made was removing "Safari" from the preview as an option. I wonder if that broke something.

    The other question is are there any options we have? I'm doing a build right now to use the wkwebview plugin and see if that makes a difference. is the UIWebVIew the default? I don't see any options to select something different.

  • Ok just tested and yea same issue... PhonegapWebViewPlus (cranberry plugin) didn't make a difference. Is there anything else we can try?

  • Ok just tested and yea same issue... PhonegapWebViewPlus (cranberry plugin) didn't make a difference. Is there anything else we can try?

    We can only wait Or if you are on a deadline and need to export to ios quick as hell, you can try ludei's webview+ (wkwebview), just export to cocoonjs from construct2 and choose the webview+ in cloud compiler.

  • Sisyphus yea i think i can wait.. the worse case would be to roll back to 195 and publish fine but i made a few significant updates to my project yesterday with 196 so I hate to have to undo that work. I'll give them a day or two to do a hotfix if they can find the root of the issue quickly.

  • I hope it can be fixed soon. :/

    Can I just disable beta updates in Steam to get the latest stable build back and load the project even if I edited some lines with r196?

  • no, once you save any changes in a newer version older versions will not open it.

  • Just tried it and I can't open it. It says it was saved with r196.

  • I have the exact same issue. Blank screen on iOS/XDK.

    If you disable beta in Steam it will download/revert to the last stable build of C2. (195)

    You need to follow these steps to be able to open your project in r195 (MAKE A BACKUP FIRST!)

    (at the bottom of the thread)

  • Bl4ckSh33p aquinn I will not recommend you to use this method, too risky and the issue is not serious, better wait for a fix.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I can't sit around waiting for a fix I'm afraid.

    The above method worked for me, but make make a backup so any damage to the source project can be undone.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)