Audio Play At Bug

  • Problem Description

    Game freezes for a second when Play At Object action is made for the first time AND when running game for the first time (doesn't happen after refreshing page).

    Attach a Capx

    https://1drv.ms/u/s!AhHSZHEulqh_gWoZ4BKI4w1QmnIk

    Description of Capx

    plays audio 3 seconds after the start of the layout.

    Steps to Reproduce Bug

    • run layout
    • watch sprite moving and how it will freeze when audio plays

    Observed Result

    game freezes when audio plays

    Expected Result

    not freeze

    Affected Browsers

    • Chrome: (YES)
    • FireFox: (YES)
    • Internet Explorer: (YES/NO)

    Operating System and Service Pack

    vista sp2

    Construct 2 Version ID

    r227 (also checked with r232)

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Just to add some information, this appears to be caused by line 2990 in the audio/runtime.js file.

    context["listener"]["setPosition"](this.listenerTracker.obj.x, this.listenerTracker.obj.y, this.listenerZ);[/code:4z6hp0i1]
    
    Not sure why it affects the object's movement though.
  • Sounds like this Chrome bug which was previously discussed here.

    Closing as this is a Chrome issue. Also it looks like as per the last comment in the Chrome bug they've already done something about this, and I verified the jank is much smaller in Canary. It probably won't be entirely eliminated though - the reason for the jank is the browser lazy-loading the positioned audio playback engine the first time you use it.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)