Construct2 freezes when saving or backing up

0 favourites
From the Asset Store
Match the similar cards with each other and free all animals!
  • I work off a .caproj file in my project folder. I don't touch the .capx in my Dropbox backup folder. I have switched to a .capx in my project folder and will start working off that. Hopefully that fixes the problem.

  • Nitro187 - the only difference I can see from those logs is when it's moving around the backupN files it gets "SHARING VIOLATION" for one of them. But then it goes ahead and carries on anyway, which is why I don't understand why it hangs, it appears to show it continued after that and it must be hanging somewhere else.

    Does this only happen if you have your actual .capx file in your Dropbox (or Google Drive) folder? You don't need to do that to back it up, just set one of your backup folders to the Dropbox and as you work on your local .capx it will copy it to Dropbox from time to time anyway. I'm pretty sure that backup process only copies a single file in one go, so it should work with these file syncing apps.

    I honestly never use the backup folder options in the preferences.... those are just set to default. It never really occurred to me before that I could just turn off backups all together - which would remove this issue... but also leave me vulnerable too. This happens when I have everything saved in the same directory, like it would normally. I never save a .capx in the same directory, the youtube video shows that just to show you the bug occurs with caproj's only. I guess it would just be awesome if there was a cancel button to close that window, so you can 'try again' or something. If that's not possible, I guess I'll just have to disable backups completely unfortunately.

  • up until this date, the problem remains. I have it since months, and update C2 regularly

  • Yeah - I gave up on hoping it would get fixed.... I just got rid of Drop Box, as the rest of the apps, such as Microsoft's One Drive, doesn't lock files.... which doesn't cause it to freeze anymore.

    Dropbox sucks.

  • Construct 2 froze on me too when trying to save. I created a new caproj and had essentially two sprites. I gave one of the sprites an Instance Variable called GridID and set it to 1. I then copied this 8 times and set the other instance variables to 2-9 respectively. When I tried to save, it just looped endlessly until I killed Construct 2 in task manager. Unfortunately, from what I've read, the Dev's will never fix this problem because they apparently require a capx in order to open a ticket... but the problem doesn't occur when I try the exact same steps in a capx project, only a caproj. Very frustrating.

  • It happens to me as well using google drive.

  • I'm also experiencing this same problem. Guess I need to Switch from Dropbox to external HDD.


  • I have recently also ran into this issue and was able to narrow down what was causing it (at least for me).

    My project is saved as a project and in that project folder I have a "REFERENCES" folder.

    In that folder I have pictures, Word documents, PDF's, Excel documents, etc...

    Construct 2 would save but it felt slow. (I would have a bunch of the documents from the "REFERENCES" folder open)

    When I had an Excel document open from that "REFERENCES" folder and tried to save my project it would freeze up.

    I tried this with other documents but so far it's only happening with open Excel files.

    Once I moved the "REFERENCES" folder outside of the project folder it no longer froze and was actually much faster in saving.

    Hope that helps.

  • Old thread, I know, but just wanted to chime in and say that it had been happening to me recently (it had happened sometimes before, but not so often.) Unlike most of those that reported the problem, I have been using a local drive.

    The best solution that seems to be working for me right now is to simply turn off Auto-backup. If this is the culprit, wouldn't it be ironic that it would be the one causing me to lose a lot of work?

    I'll be writing my own service that backups the caproj, so I think that won't interrupt whatever C2 is doing.

  • Just wanted to say that the same thing is happening to me since the latest update, the auto-backup hangs for a really long time whenever I save

  • Well, it turns out that no, disabling auto-backup did not actually remove the issue. I will now disable Auto-save and see if that helps. (I'm still suspecting the 'Auto' features. I have Auto-save set to 'Hourly', and I have just come back a little after an hour to save my project. The Auto-save will kick in if there's activity in C2, and it so happens that my first command was to save the project.)

    Ashley, I know that this is a highly irregular bug and it might be something to do with the file system (I've had my own code demons dealing with stuff like this). But in the hopes of finding a workaround to make the save function work reliably I took a screencap of the latest 'hang':

    On the status bar it stops at Saving project settings. I noticed that the uistate.xml was successful in saving the latest, but unfortunately, the .caproj did not save.

    Perhaps there is a workaround to bypass certain procedures and simply get on with saving the 'essential' stuff, like the events? It's just that I'm sometimes losing a lot of progress and it's quite unnerving to know that my previous successful save might be my last. FWIW, I'm using a local drive; I run as Administrator in my machine. Again, I am looking at disabling Auto-save, and hopefully that works. Thanks for reading.

    SecondDimension, now that you mention it, it does seem that it started happening when I upgraded from r250 to r256 recently. Of course, this has been happening before, but I concede that when it did happen I was also using cloud storage (both Dropbox and OneDrive in separate instances). And I don't recall this happening since I started this project last year, and I've been on r250 for a long time before upgrading. I don't mind downgrading, though I'll be darned if that's the reason.

    But like I said, I'll switch off Auto-save, and see what happens.

  • Well, as a follow-up -- for the sake of historical records, I guess -- the Auto-save/Auto-backup seemed to have a helped for the past days since turning off Auto-save. At least it was saving quite quickly. Unfortunately, it has done it again. And, like before, it stops on 'Saving project settings...'. The progress bar is up, but shows no activity.

    As a last-ditch effort, I will downgrade to r250 which is the build I was on before upgrading recently.

  • Just reporting in after 2 weeks of working in C2. Btw, for context, my observations are based on working full 12-18 hour days, 7 days/week. I happy to report that after 2 weeks after switching from R256 to R250 I have not encountered the Save lock-up bug. This, more or less, confirms my recollection that this bug was never present in R250 to begin with.

    Because this is an Editor bug, I'd be willing to road-test R251 up to R253 (it is known that R254 has this save lock-up bug) in the same conditions as I've been using R250, if only to have a behavioural comparison for some 'speculative' debugging of the Editor's code between the builds -- to know in which build the save lockup bug started ocurring. But I can only do this if there was some interest in solving this bug. If not, I won't be inclined to risk the integrity of my work.

    Thanks for listening.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • It would be very useful to know if a specific release caused a change, but given that we have not touched the saving code since r250, I would suspect this is actually a sporadic issue that has been mis-attributed.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)