0 Favourites

SpriteFont (v0.99.5RC) - new update, small bugfixes

This forum is currently in read-only mode.
  • "Is Writing" and "on character written conditions" do not fire for the last character.

    Using a font object with an autostarting fade behavior seems to break the edit box

    or am I just doing it wrong?

    EDIT: it seems that "show text" does not create objects until the next frame, as I can't pick them within the same event... and that's not really useful (I want to start a fade behavior on them)

  • This will be really useful for 8-bit style games

  • I'm really glad you're going to polish this one. It's an important plugin for construct.

  • Does the SpriteFont.Width value even work? I'm trying to set my graphical dialog box - a speech bubble sprite - to the width of the SpriteFont textbox, but it appears at a width lesser than the width of the textbox.

    Take a look at this to see what I mean.

  • This is brilliant, thanks!

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Worderfull job with the plugin Lucid!!

    Here's a tiny 'bug' ..

    When you enable the "Scroll Wraparound: X or Y" the text if scrolled in X+Y (together), leaves a trail of a couple of pixels which makes some pixel fonts unreadable.. if it's disable there's no problem at all.

    Im loving this plug and i hope you can squash all those bugs out

  • unfortunately, in a pc change the source code is gone

    and this was made when I was just learning to program

    so it will stay with the current bugs

    there is a user named Minor though, that says he's used it in every project of his, and that it causes him no problems

    he offered to post a tutorial or example of how to use it without problems, I think I'll take him up on that offer, because this is the most asked about plugin I've made, and I won't have time to rewrite it anytime soon

    edit: and thanks

  • Wow Lighting reply

    Yes i've seen Minor around... i did learn alot from his SkullKoBan (forum/viewtopic.php?t=6655) tutorial / .cap as it uses the SpriteFont plugin. I'll keep looking for further developments than... thanks again!

  • I always forget to check this thread.

    unfortunately, in a pc change the source code is gone

    and this was made when I was just learning to program

    so it will stay with the current bugs

    there is a user named Minor though, that says he's used it in every project of his, and that it causes him no problems

    he offered to post a tutorial or example of how to use it without problems, I think I'll take him up on that offer, because this is the most asked about plugin I've made, and I won't have time to rewrite it anytime soon

    edit: and thanks

    I can do this if you like lucid. Like I've said I've never had any problems but maybe I'm just doing anything too fancy with the plugin. Don't know how I'd do it maybe a layout for different things the plugin can do.

    Wow Lighting reply

    Yes i've seen Minor around... i did learn alot from his SkullKoBan (forum/viewtopic.php?t=6655) tutorial / .cap as it uses the SpriteFont plugin. I'll keep looking for further developments than... thanks again!

    Ah good to know someone found SkullKoBan useful

  • Yes ! SkullKoBan! the best tribute-tutorial around Thanks Minor!

  • I'm having trouble.. it randomly cuts off text after showing a few letters with "show text"

    it shows correctly when first run, then upon layout changing and back it doesn't show anything

  • help us out minor

  • help us out minor

    I'll try

    Like I said before maybe it's just me trying nothing spectacular with SpriteFont and thats why I have no problems with it

  • I encountered a really weird bug with the SpriteFont plugin in Construct 0.99.96. When I add more than 1 SpriteFont object to my layout, it instantly crashes when trying to run the cap. It doesn't matter if those are instances of the very same object or two different SpriteFont objects. I'm using SpriteFont version 0.99.99RC.

    To make it even weirder, this only happens on my XP home SP3 machine, but not on my Win7 64bit home premium pc.

    Can anyone make any sense of that?

    EDIT: also happens in 0.99.95. Even went back to 0.99.7... seems to happen no matter which version.

  • excelent plugin, thanks!

    just a question.. can I limit the number of letters in the spritefront? if yes, how?

    edit: I used gettokken for it

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)