0 Favourites

Online Multiplayer test. Please

  • Hello, just been tinkering with some net coding stuff. It would be awesome if some fantastic forum developers could give the "game" a quick test. It's very rudimentary, most bugs are out and there was no bugs cropping up in the last dozen tests.

    If any bugs alert windows popup let me know. Not sure if i'll bug fix anytime soon; as it's already taken 3 days away from my primary game.

    <font size="5">Multiplayer test shooter</font>

    Important

    * Tested on Chrome, FF, Opera. May not work with IE

    * Click "Join Game". DON'T CLICK ON IT MORE THAN ONCE. BE PATIENT. There is a 3 second delay after connecting to the server to validate the arena room has been joined. Should take apx 4 to 10 seconds to join the game. Clicking on Join Game more than once, will just break it. Might fix later :P

    * You will Enter the match with 10 seconds of shields. Your shield will block your own shots.

    * Controls are WASD

    * Shoot with left clickwdsss

    * 10 health

    * get disconnected when 0 health

    * Mouse Aiming is funny when at the arena borders(fix is low priority)

    * no dead reckoning,

    * no client prediction

    * websocket, not UDP. So there is a delay. Attempted to balance shooting a little

    * will leave the server up, but my computer sleep modes at night.

    * timeout after 3000 seconds

    * No idea if it works outside my network

    * the server I'm running IP might change. tonight, tomorrow, next month

    * 100 player limit.... I garuntee the game won't run well. I have no idea if it will run well with 1 player over the internet :D

  • jayderyu Pretty cool! <img src="smileys/smiley4.gif" border="0" align="middle" /> I just tested your game did you use a plugin or make your own? There was no sound was there suppose to be?

  • Thank you very much. Appreciate the comment.

    I wrote the plugin myself.

    No sound was added to the game at all. the game itself was a quick throw together

    Must reiterate. the aiming is wonky at the side :(

  • For a quick throw together it's working quite nicely. I experienced no lag, or time delays logging in or playing. Also aiming worked for me. I was playing on a almost 4 year old laptop with a old out dated graphics card.

    I would like to try this with 100 players just to see how it performs.

    I think you got something good started here keep at it.

  • Wink

    aaahhh... I think the 100 players would kill my bandwidth :D Your right though. I would like to see performance at 4/8/16 players. It's not written to handle any specific number. So I'm sure problems will occur with only a handful.

    Once I finish my Ouya game I'll probably see if there is interest to taking local mp, to online Mp.

    I'm located in Vancouver, BC, Canada as is the server. Let me know where your located so I know the distance is involved.

    I'll be leaving the server up. But I can't garuntee how it will work through the night with sleep mode on. Also i'll be ending my client connection tonight. So the server might/probably be empty.

  • I live in Juneau, Wisconsin, USA.

    Maybe tomorrow around 8:00am Central Standard time when Ashley, and everyone is usually on line would be a good time to try to get more players to test with.

  • well. I'll try to have everything up and running. Even if I'm a sleep or getting my kids off to school.

    Thanks for the testing Wink :) I think I finally saw some jumping, but it was quick and didn't seem so bad. Considering there is no compensation.

  • Not loading for me :(

    I waited about 30 seconds and tried a few times on chrome.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • working for me. but game created two characters for me, i was controlling both at the same time.

    there was some minor lag too. my enemy was making little jumps/teleports in game-space :)

  • Tested and worked nicely.

    At the beginning in first 10sec of the game I have some lag but then all normalised.

    You have done an extreme good work, keep going. <img src="smileys/smiley32.gif" border="0" align="middle" />

  • Nice!

    I tried with two tabs and I think the delay was around 1sec, but it would be good already for fun/chat games

    (btw I hate wasd)

  • Peret

    uuggg, your not the only one then. That's blowing my mind. Last night I had internet problem. So I rebooted the network. This gave my server a new IP. With a new IP I needed to update the game connection. I updated IP. Now here is the strange part. FF, Opera no problem. They get the new Ip address that was uploaded to the website. However, and this boggles me. Chrome is not. In fact I cleared various browsing data to empty the cache. Yet still on a fresh download the old IP address stuck in the code.

    I'm not sure why our 2 copies of Chrome are using old versions. Maybe there is a webserver setting I can check on. It's annoying me :(

    ebrar

    Two? that's a first, what's odd is that you were controlling them both. can you let me know your OS, hardware and location.

    As for the mini teleports. That's expected behaviour. That's caused by two factors.

    1. TCP/WS. TCP requires that the message is verified by the client and server. So the data is sent, recieved, then a confirmation is sent back before it's used. Then the data is ordered and used(if out of order) This increases overall lag. UDP(which is not standard yet) is a fire and forget. So TCP is naturally laggy.

    2. Well developed TCP games even in real time. use dead reckoning and client prediction. These allow for player correction that is invisible to other players(unless extreme lag). however, the test shooter is very brute force. If the game clients are out of 'sync' the game will do a brute force correction which will look like teleport. So this is as intended, but only because it's simple... and not a feature :P

    tyfricko

    I'm not sure what's going on here. My friend who lives in the same city had a similar 10 seconds problem. However his starts fine in first 10 seconds, but then has lag problems after that.

    Interesting enough. That's why the game starts entry players with 10 seconds of shields. So you can't be hit, and you can't hit back. The 10 second shield is only to compensate for entry syncing, memory sorting...

    lemo

    I understand you pain. I just added the referenced bindings(ZQ) to the project. I'm not sure when it will go live, but it's there.

    I ended up using WASD or left keyboard bindings because of manual key checking for state updates. Also I'm not sure I will add more weapons, but if I do I wanted quick access to the number keys.

    As for lag, well sounds like your in Europe. I consider 1 second lag to be amazing considering I'm in West Coast Canada :D. If only we had R-UDP :D. We could probably cut that in half or more :D

    Thanks for the positive comments for those that managed to play.

  • jayderyu

    windows 7, [hardware? more specifically?], location: istanbul, Turkey

  • ebrar

    hmm. Well I can see why you would get a lot of teleporting :P. Istanbul, that's a long trip for data package for real time game play :)

    I can't however, figure why you had two you could control.

    StartPage

    Click to join

    on joined store local player id

    change layout

    on start of arena layout

    create player

    player.id = local player id

    repeat loop for each player already in room

    --create player

    --player.id = players already in room

    hmm, I think what might have happened. Was that due to latency. Your client recieved the roomlist BEFORE 'create room players' started. So with the updated room list with you already in the list. It created your on start, and created another... eh. i'm not sure, but I think I can block it.

    However, this strikes me a game logic bug, and not a networking problem. Which is good :)

    edit: fixed for next update

  • Just made an update.

    * improved player room count(not entirely fixed)

    * added the french 'qz' keys for WASD

    * characters move a little faster

    * bullets move a little faster

    * reduncacy check to avoid player duplication

    * plugin updates

    * Health update more often

    * info on the current number of players in the match

    for those unable to connect in Chrome. I managed to get it to work, but I had to wile almost all my cache data. If there is no connection. Then that is likely due to the game running under an old c2Runtime.js :(

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)