most of the games in the arcade aren't loading for me.

0 favourites
  • 4 posts
From the Asset Store
Progress\Loading Bar. Now Load you game like a Professional.
  • For some reason most of the games in the arcade won't load, they just give me a red progress bar and stay on the loading page.

    It has to be an issue with my LAN, because it will work if I am using a different wifi connection.

    it seems like only the really basic games work. for example "red tie runner" doesn't work but "18 second challenge plus" will run fine.

    these are the errors i'm getting in the console.

    Failed to load resource: the server responded with a status of 403 (Forbidden)

    Application Cache Error event: Resource fetch failed (403)

    "An iframe which has both allow-scripts and allow-same-origin for its sandbox attribute can remove its sandboxing."

    anyone know what's wrong?

  • I found that a game that I uploaded also wasn't working anymore. Same 403 Forbidden errors on the images. I tried re-exporting and updating the game, but that just seemed to make it worse, as now the data.js file is getting the 403 Forbidden error.

    Also, the server spits this out if I try to view the game iframe:

    [InvalidOperationException: Sequence contains more than one element]   System.Data.Linq.SqlClient.SqlProvider.Execute(Expression query, QueryInfo queryInfo, IObjectReaderFactory factory, Object[] parentArgs, Object[] userArgs, ICompiledSubQuery[] subQueries, Object lastResult) +4506
       System.Data.Linq.SqlClient.SqlProvider.ExecuteAll(Expression query, QueryInfo[] queryInfos, IObjectReaderFactory factory, Object[] userArguments, ICompiledSubQuery[] subQueries) +188
       System.Data.Linq.SqlClient.SqlProvider.System.Data.Linq.Provider.IProvider.Execute(Expression query) +500
       System.Data.Linq.Table`1.System.Linq.IQueryProvider.Execute(Expression expression) +50
       System.Linq.Queryable.SingleOrDefault(IQueryable`1 source, Expression`1 predicate) +490
       V1.Game.IncrementPlaysCount(String playToken) +2946
       Index.ProcessRequest(HttpContext context) +639
       System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +913
       System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +165
    @Tom, could you look into this?
    EDIT: I suppose I should actually link my game.
    [url=] ... rld-1-3750[/url]
  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • If I request the files in private (incognito) mode, I still get the 403 forbidden errors. If I use a proxy, I can receive them just fine. I guess the arcade hates my IP address now.

  • I'm getting this same problem. It's very frustrating, I want to show off my game(s) to possible employers.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)