Critical Error

  • Hello, a lot of times when I try to open the Construct forums or go to a post, I get this message:

    Critical error

    This should not of happened. Please contact support.

    StackExchange.Redis.RedisConnectionException: No connection is available to service this operation: GET UserSession.362456; SocketClosed on Construct3.redis.cache.windows.net:6380/Interactive, Idle/MarkProcessed, last: GET, origin: ReadFromPipe, outstanding: 0, last-read: 0s ago, last-write: 56s ago, keep-alive: 60s, state: ConnectedEstablished, mgr: 9 of 10 available, in: 0, last-heartbeat: 0s ago, last-mbeat: 0s ago, global: 0s ago, v: 2.0.601.3402; IOCP: (Busy=0,Free=1000,Min=200,Max=1000), WORKER: (Busy=1,Free=32766,Min=200,Max=32767), Local-CPU: n/a ---> StackExchange.Redis.RedisConnectionException: SocketClosed on Construct3.redis.cache.windows.net:6380/Interactive, Idle/MarkProcessed, last: GET, origin: ReadFromPipe, outstanding: 0, last-read: 0s ago, last-write: 56s ago, keep-alive: 60s, state: ConnectedEstablished, mgr: 9 of 10 available, in: 0, last-heartbeat: 0s ago, last-mbeat: 0s ago, global: 0s ago, v: 2.0.601.3402 --- End of inner exception stack trace --- at StackExchange.Redis.ConnectionMultiplexer.ExecuteSyncImpl[T](Message message, ResultProcessor`1 processor, ServerEndPoint server) in C:\projects\stackexchange-redis\src\StackExchange.Redis\ConnectionMultiplexer.cs:line 2235 at StackExchange.Redis.RedisBase.ExecuteSync[T](Message message, ResultProcessor`1 processor, ServerEndPoint server) in C:\projects\stackexchange-redis\src\StackExchange.Redis\RedisBase.cs:line 54 at StackExchange.Redis.RedisDatabase.StringGet(RedisKey key, CommandFlags flags) in C:\projects\stackexchange-redis\src\StackExchange.Redis\RedisDatabase.cs:line 2281 at C3.Code.Controls.Application.Caching.Distributed.DistributedCacheController.Get[T](String cacheKey) in C:\Construct.net\Source\C3Alpha2\Code\Controls\Application\Caching\Distributed\DistributedCacheController.cs:line 107 at C3.Code.Controls.Application.Caching.Manager.Manager.Get[T](String key, Func`1 getFromExternFunction, Boolean skipLocalCaches) in C:\Construct.net\Source\C3Alpha2\Code\Controls\Application\Caching\Manager\Manager.cs:line 132 at C3.Code.Helpers.UserSession.Functions.GetCurrentUserSession(HttpContext context) in C:\Construct.net\Source\C3Alpha2\Code\Helpers\UserSession\Functions.cs:line 70 at C3.Pages.Master_Pages.Global.Page_Init(Object sender, EventArgs e) in C:\Construct.net\Source\C3Alpha2\Pages\Master Pages\Global.Master.cs:line 114 at System.Web.UI.Control.OnInit(EventArgs e) at System.Web.UI.Control.InitRecursive(Control namingContainer) at System.Web.UI.Control.InitRecursive(Control namingContainer) at System.Web.UI.Control.InitRecursive(Control namingContainer) at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)StackExchange.Redis.RedisConnectionException: SocketClosed on Construct3.redis.cache.windows.net:6380/Interactive, Idle/MarkProcessed, last: GET, origin: ReadFromPipe, outstanding: 0, last-read: 0s ago, last-write: 56s ago, keep-alive: 60s, state: ConnectedEstablished, mgr: 9 of 10 available, in: 0, last-heartbeat: 0s ago, last-mbeat: 0s ago, global: 0s ago, v: 2.0.601.3402

    Do you know why this is and can you please fix it? I posted this here because I don't know where else to post it. The bug section on GitHub wouldn't work because I can't fill out all of the forms. Could you please fix it and/or tell me where to post bugs like this.

    Thank you,

    Give me a Pixel

  • BUMP.

    This should definitely be addressed soon. Ashley

  • BUMP

    Cant login, every page in construct.net can occur critical error.

  • getting the same error trying to load the editor.

  • Getting the same error with Chrome.

    Switched to Edge and get this... it came up with a big red warning letting me know the site was unsafe.

    And it's crashing incessantly in Edge as well.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I'm also having this problem, my saves are also randomly being stuck at 0% forcing a refresh/restart causing all work done to be lost. I was going to buy a license to use CS3 for a project but at this rate theres absolutely no point.

  • Looking into this, looks like a possible Azure network problem. It seems to of resolved itself as of time of writing.

    raikoification what version are you using? The saves are not tied to our network at all as far as I am aware.

  • We identified performance degradation linked to the roll out of the new arcade (namely from significant increase in visitors including web crawlers). In response we've taken a few steps to significantly improve performance, and are upgrading our webservers to add additional capacity. From what I'm measuring, everything should be running a lot smoother now.

  • Looking into this, looks like a possible Azure network problem. It seems to of resolved itself as of time of writing.

    raikoification what version are you using? The saves are not tied to our network at all as far as I am aware.

    It was strange. In the editor I could keep reloading and sometimes it gave me the right version, sometimes it logged me in and sometimes it didn't.

  • Make sure C3 is available for use in offline mode as it will then run all features enabled even if on the rare occasion where the website is experiencing issues.

  • Thank you. The Forums seem to work nicely now.

  • Looking into this, looks like a possible Azure network problem. It seems to of resolved itself as of time of writing.

    raikoification what version are you using? The saves are not tied to our network at all as far as I am aware.

    I did not check what version it was but I'm pretty sure I used the latest as I just started using CS3 yesterday to test before I bought.

    How do you enable offline mode? I was trying to enable it yesterday so I could continue working on the project but couldn't seem to do it ( I even downloaded the desktop client). I'm really not too sure what was with the save but what ended.up happening is pretty much I would have to save after every edit as after 5-30 seconds things broke. Saving would cause it to freeze and be stuck at 0%. If I tried to just continue working it would be fine ( aside from inability to save ) however preview wouldnt work either.

    I'm assuming it's all related to the azure problem so hopefully it's fixed (can't check right now).

  • raikoification if you're new to Construct, make sure to only use the latest stable releases. Beta releases can contain bugs, and are not as thoroughly tested.

    To run offline, you need to open C3 and wait for a notification to appear in the corner saying C3 is ready to use offline. If you close it before then, it hasn't finished downloading everything it needs so won't work offline. Once you see the notification, visiting editor.construct.net will work even if you are offline.

  • We identified performance degradation linked to the roll out of the new arcade (namely from significant increase in visitors including web crawlers). In response we've taken a few steps to significantly improve performance, and are upgrading our webservers to add additional capacity. From what I'm measuring, everything should be running a lot smoother now.

    It's back again.

    Critical error

    This should not of happened. Please contact support.

    System.IndexOutOfRangeException: Index was outside the bounds of the array. at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add) at C3.Code.Controls.Application.Caching.Redis.PubSub.PubSubController.OnSubscribed(RedisChannel channelName) in C:\Construct.net\Source\C3Alpha2\Code\Controls\Application\Caching\Redis\PubSub\PubSubController.cs:line 58 at C3.Code.Controls.Application.Caching.Redis.PubSub.PubSubController.SubscribeToCacheKey(RedisChannel cacheKey, Action`2 onMessageReceived) in C:\Construct.net\Source\C3Alpha2\Code\Controls\Application\Caching\Redis\PubSub\PubSubController.cs:line 46 at C3.Code.Controls.Application.Caching.Manager.Manager.Callbacks.OnGotten[T](String cacheKey, CacheType fromType, T objectGot) in C:\Construct.net\Source\C3Alpha2\Code\Controls\Application\Caching\Manager\Callbacks.cs:line 99 at C3.Code.Controls.Application.Caching.Manager.Manager.Get[T](String key, Func`1 getFromExternFunction, Boolean skipLocalCaches) in C:\Construct.net\Source\C3Alpha2\Code\Controls\Application\Caching\Manager\Manager.cs:line 158 at C3.Code.CachingNew.Methods.GetCachedHashSet[T](String cacheKey, Func`1 getFromExternFunction) in C:\Construct.net\Source\C3Alpha2\Code\CachingNew\Methods.cs:line 115 at C3.Code.Caching.SystemMessages.MessageReportIDs.OnNewReportCreated(MessageReport newReport) in C:\Construct.net\Source\C3Alpha2\Code\CachingNew\SystemMessages\MessageReportIDs.cs:line 31 at C3.Code.Models.SystemMessages.MessageReport.PostCreated(DBContext db) in C:\Construct.net\Source\C3Alpha2\Code\ModelsNew\SystemMessages\MessageReport.cs:line 72 at C3.Code.BaseClasses.CachingNew.DatabaseBackedCachableModel`2.OnCreated(DBContext db, T newRec) in C:\Construct.net\Source\C3Alpha2\Code\BaseClasses\CachingNew\DatabaseBackedCachableModel.cs:line 217 at C3.Code.BaseClasses.CachingNew.DatabaseBackedCachableModel`2.CreateNew(DBContext db, T2 newRec) in C:\Construct.net\Source\C3Alpha2\Code\BaseClasses\CachingNew\DatabaseBackedCachableModel.cs:line 202 at C3.Code.BaseClasses.CachingNew.DatabaseBackedCachableModel`2.CreateNew(T2 newRec) in C:\Construct.net\Source\C3Alpha2\Code\BaseClasses\CachingNew\DatabaseBackedCachableModel.cs:line 209 at C3.Code.Helpers.SystemMessages.Reports.CreateSystemMessage(String title, String reportData, MessageType messageType, String ipAddress, Int32 cap) in C:\Construct.net\Source\C3Alpha2\Code\Helpers\SystemMessages\CreateReport.cs:line 67 at C3.Code.Helpers.Error.Functions.RecordError(Exception exception) in C:\Construct.net\Source\C3Alpha2\Code\Helpers\Error\Functions.cs:line 75 at System.Web.UI.Control.OnLoad(EventArgs e) at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

  • Tom Sorry, I didn't see this post and logged a bug report.

    The issue is still happening today.

    For me Firefox shows both Critical Error and 500 Exception on most pages. Have to reload each page several times. Chrome shows 500 Exception only.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)