CocoonJs and Froyo/Gingerbread(Android)

  • I can't run cocoonjs project on Froyo and Gingerbread.

    any clues?

    Log :

    E/IDTKLog ( 5096): IDTK_LOG_ERROR: [IDTK] Invoked in function static com::ideateca::core::SPData com::ideateca::core::io::AbstractFileSystem::loadFile(const std::string&) line 47: IllegalArgumentException: Cannot open the given '/data/data/com.lastseal.smasher/files/ls.cdf' file path.

    W/ActivityManager( 2532): Launch timeout has expired, giving up wake lock!

    W/ActivityManager( 2532): Activity idle timeout for HistoryRecord{480f5ad8 com.lastseal.smasher/.smasherActivity}

    I/dumpstate( 5106): done

    D/Zygote ( 2415): Process 5096 terminated by signal (11)

    I/ActivityManager( 2532): Process com.lastseal.smasher (pid 5096) has died. <img src="smileys/smiley19.gif" border="0" align="middle" />

  • Pls, y rly need help whit this problem <img src="smileys/smiley19.gif" border="0" align="middle" />

  • You should contact Ludei about this issue. They are the ones who make CocoonJS.

  • But the game is developed in C2. I made other game in C2 and run perfectly on android 2.x. The only diferrence was the version of C2.

    The first game was developed C2 r114 and work perfectly on android 2.x

    The second game was developed C2 r126 and dont work =( on androiid 2.x , only work on android 4.x.

    <img src="smileys/smiley19.gif" border="0" align="middle" />

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • According to ludei, cocoonjs only supports 2.3 and up.

  • The log is showing an error in CocoonJS, not Construct 2. You should still report it to them.

  • try this: open your project file in a text editor and change the version back to the older official supported one. Then open in the older verion, and export to cocoonjs.

    May or may not work.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)