[Solved] Finished my game but having problems with Cocoon.io

0 favourites
  • 7 posts
From the Asset Store
five golem elements Sprites Sheet.Best for enemy or villain game characters.
  • Dear all,

    I have finished my first game and I'm trying to save it as APK using Cocoon.io but I'm having some issues:

    1. When I export as Webview+, the sound doesn't work.

    2. When I export as Canvas+, the Cocoon splash screen shows but then I get black screen. Am I missing some plugins?

    3. When I export as Webview+ with Google Play Games Social API, I also get black screen.

    BTW my game is on Google Play Store but I have uploaded only Alpha version.

    Please help! I'm losing my nerves!!!

  • I have fixed my problems by doing the following:

    1. Create new project

    2. Delete all installed plugins in Cocoon.IO

    3. Choose Android export (this installs plugins necessary for Android)

    4. Choose Webview+ export option

    But when I add MoPub ads plugin, I get black screen again. I cannot make these external things to work: Google Play Games Social API, MoPub ads etc. This sucks...I really thought that this will be easy. It seems that publishing for Android is much harder than making the actual game.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • We all feel your pain.

  • The solution was to go to the folder where you exported for Cordova, open "www" subfolder and delete config.xml file. The next thing is to zip all files inside "www" folder and upload them to Cocoon.IO.

  • I won't be using Construct 3 if there isn't a built in Compiler.

    https://forums.cocoon.io/t/compiler-doi ... sh/5452/27

    They're blaming my Project.

    "If it were the Project then why does a project that worked before not work now? It can't be the Project. Then please explain why code that worked before, without being modified at all whatsoever, doesn't work now. Something that before this happened. I didn't change ANYTHING. This the file that I restored, and did not modify. It used to work, and now it doesn't.

    Please explain that. The code is exactly the same. It worked before, and now it doesn't. So it cannot be the Project. Because if it were the Project, the one that was working would still be working, would it not?"

  • I got black screen as well.. but when I changed to WebView+ it fixed it... yaay!

  • Okay guys, quick and simple: I am trying to wrap my game via Cocoon but all the tuts are outdated or/and contradictory and whatever I do or try I keep getting a "Andoird devapp compilation failed" error and this is as far as it goes. Do anybody has a valid UP TO DATE tuts on the matter?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)