[PLUGIN] "Share" Popup Fixed (Fb, G+, Twitter etc.) V3.5

  • I seem to be having a little trouble with the share image to facebook function.

    This is my setup, is this as expected?

    In Firefox, upon clicking share, a new tab opens in the browser, the tab title saying "Connecting..." and the helper text at the bottom of the screen saying "Waiting for Facebook...". After about 30 seconds, it times out and leaves a blank screen.

    In Chrome, upon clicking share, a new window opens that tries to connect to facebook, but ends up failing. Screengrab below:

    On Internet Explorer, I was able to proceed to Facebook and post something, however no image was displayed:

    Clicking on the link takes me to the following URL which is stuck on an endless load loop:

    URL REMOVED[/code:scfigsnw]
    
    Firefox Version 32.0.1.
    Chrome Version 35.0.1916.153
    Internet Explorer Version 11.0.9600.17278
    
    Let me know if you need any further information! Tried to be as thorough as I could.
    
    Thank you.
    [u][i]
    Edit: Update:[/i] [/u] I also tried this using R0J0hound's Paster plugin as an alternative to the CanvasSnapshot method, and incurred the same result on all three browsers. Thought this was a relevant point to add.
    
    [url=http://goo.gl/iwYgy4]http://goo.gl/iwYgy4[/url] for the CanvasSnapshot method.
    [url=http://goo.gl/4lBhL7]http://goo.gl/4lBhL7[/url] for the Paster method.
  • I seem to be having a little trouble with the share image to facebook function.

    This is my setup, is this as expected?

    In Firefox, upon clicking share, a new tab opens in the browser, the tab title saying "Connecting..." and the helper text at the bottom of the screen saying "Waiting for Facebook...". After about 30 seconds, it times out and leaves a blank screen.

    In Chrome, upon clicking share, a new window opens that tries to connect to facebook, but ends up failing. Screengrab below:

    On Internet Explorer, I was able to proceed to Facebook and post something, however no image was displayed:

    Clicking on the link takes me to the following URL which is stuck on an endless load loop:

    Firefox Version 32.0.1.

    Chrome Version 35.0.1916.153

    Internet Explorer Version 11.0.9600.17278

    Let me know if you need any further information! Tried to be as thorough as I could.

    Thank you.

    Edit: Update: I also tried this using R0J0hound's Paster plugin as an alternative to the CanvasSnapshot method, and incurred the same result on all three browsers. Thought this was a relevant point to add.

    http://goo.gl/iwYgy4 for the CanvasSnapshot method.

    http://goo.gl/4lBhL7 for the Paster method.

    You are doing it a little bit wrong.

    This is what you need to do :

    OnCanvasSnapshot -> Upload CanvasSnapshot.

    On Upload finished -> Share via facebook -> Share.LastData

    This should work, checkout the V3 .capx example for upload.

  • Ahhh thank you! I will try this now.

  • Ahhh thank you! I will try this now.

    You need to have a PHP hosting to do the upload part.

    And to download the screenshot you can do :

    Browser Object -> Invoke Download -> canvassnapshot

  • Just to let you know that I got it working just fine, now! Thanks for your help with troubleshooting! it was only not working due to my incorrect setup, as you said.

  • Just to let you know that I got it working just fine, now! Thanks for your help with troubleshooting! it was only not working due to my incorrect setup, as you said.

    Great!

  • Hello again!

    Trying to modify this a little, so that I can share a cropped image. I am using a plugin named Paster to do this, which outputs .png files.

    This doesn't seem to be working as smoothly with the Share plugin, however.

    I modified createimg.PHP to create png files instead, and checked the image it created on our server in order to make sure it created it correctly, which it did. However, upon sharing to the user's Facebook wall, no image is displayed.

    My question is: can Share currently only support JPEGs? If so, I would like to request an extension to also support PNGs

    Thank you.

  • Hello,

    I just purchased your plugin a few hours ago and recieved two e-mails from PayPal: One confirming that the money has been send and one confirming that the money has been recieved. None of those e-mails contained a download link for the addon. Will I get another e-mail or did something go wrong somehow? I can prove payment of course.

  • Hello,

    I just purchased your plugin a few hours ago and recieved two e-mails from PayPal: One confirming that the money has been send and one confirming that the money has been recieved. None of those e-mails contained a download link for the addon. Will I get another e-mail or did something go wrong somehow? I can prove payment of course.

    Yes you will get 3th email from me soon as possible. (I know your mail) Sorry for the delay.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Awesome!

  • CreativeMind

    Mail is send sorry for delay.

    Sailer

    Thanks!

  • I have recieved your e-mail and installed the plugin, thanks!

    Sadly, I already have to report a few bugs concerning sharing via facebook:

    1. When sharing via facebook, I wanted to use a redirect URL and entered a link to an app on the Google Play Store. The link to the app works fine, but the title and the description are not shown anymore on the facebook post. (I tried to use another URL, e.g. to the home page of Google Play Store, and then it worked). Could you fix this somehow? It would be nice if the people on facebook could see the full post, then click on it and enter the app site on Google Play Store directly.

    2. I can't use hashtags inside the title or description. I tried using %23, but it didn't work either.

    3. Using quote signs inside the title or description leads to backslashes in the facebook post somehow. Do I need to enter something else to avoid this?

    4. This is a major problem for me: When sharing via facebook, the wall posts always show 'weebe.nl' at their bottom. Weebe.nl is your own site, isn't it? I can truly understand that you want to make money (like everybody else here) and that you therefore need to advertise your plugin. But please understand that other people might want to make money, too. As I am creating commercial games, I do not want to have advertisements of other people or companies within them - I do not mean to be rude to you or anything, that's just how business is. Could you please offer the possibility to turn the 'weebe.nl' inside the posts off?

    And one last question:

    I can't host any files myself so far. Can anyone recommend a trustworthy, free file hoster in order to upload images, so that they can be shown in facebook posts (Dropbox won't work for this)?

    I hope you can help me with that. Many thanks in advance!

    P.S.: I am not a native English speaker, you might excuse my (sometimes) horrible grammar!

  • I have recieved your e-mail and installed the plugin, thanks!

    Sadly, I already have to report a few bugs concerning sharing via facebook:

    1. When sharing via facebook, I wanted to use a redirect URL and entered a link to an app on the Google Play Store. The link to the app works fine, but the title and the description are not shown anymore on the facebook post. (I tried to use another URL, e.g. to the home page of Google Play Store, and then it worked). Could you fix this somehow? It would be nice if the people on facebook could see the full post, then click on it and enter the app site on Google Play Store directly.

    2. I can't use hashtags inside the title or description. I tried using %23, but it didn't work either.

    3. Using quote signs inside the title or description leads to backslashes in the facebook post somehow. Do I need to enter something else to avoid this?

    4. This is a major problem for me: When sharing via facebook, the wall posts always show 'weebe.nl' at their bottom. Weebe.nl is your own site, isn't it? I can truly understand that you want to make money (like everybody else here) and that you therefore need to advertise your plugin. But please understand that other people might want to make money, too. As I am creating commercial games, I do not want to have advertisements of other people or companies within them - I do not mean to be rude to you or anything, that's just how business is. Could you please offer the possibility to turn the 'weebe.nl' inside the posts off?

    And one last question:

    I can't host any files myself so far. Can anyone recommend a trustworthy, free file hoster in order to upload images, so that they can be shown in facebook posts (Dropbox won't work for this)?

    I hope you can help me with that. Many thanks in advance!

    P.S.: I am not a native English speaker, you might excuse my (sometimes) horrible grammar!

    Thanks for the bug reports. Will work on it.

    To hide weebe.nl you need to have your own website with PHP hosting and contact me. It isn't for advertising, i would hide it if i could, but because the files are located on weebe.nl, facebook wants to show the domain.

    You need a php server for upload function of this plugin.

  • When sharing on facebook it says "WEEBE.NL" in the bottom of the post - because the link refers to a /share.php-page on your site. Could you please make this share.php a part of your package so we can upload it to our own server and get our own domain featured in the posts?

  • When sharing on facebook it says "WEEBE.NL" in the bottom of the post - because the link refers to a /share.php-page on your site. Could you please make this share.php a part of your package so we can upload it to our own server and get our own domain featured in the posts?

    Yes offcourse V4 will have the option to choose your own server or weebe.nl

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)